洛谷P2889 [USACO07NOV]挤奶的时间Milking Time

题目描述

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

奶牛Bessie在0~N时间段产奶。农夫约翰有M个时间段可以挤奶,时间段f,t内Bessie能挤到的牛奶量e。奶牛产奶后需要休息R小时才能继续下一次产奶,求Bessie最大的挤奶量。

输入输出格式

输入格式:

Line 1: Three space-separated integers: N, M, and R
Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

输出格式:

Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

输入输出样例

输入样例#1:

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

输出样例#1:

43

题解

貌似这题是个区间dp吧,也貌似是个背包(排序之后)
思路:将区间按左端点从小到大的顺序排序,然后就变成了类似于求最长不下降子序列的问题。
假设dp[i]代表以i结尾的最大不重复区间和,那么动态转移方程就是:dp[i]=max(dp[j]+w[i])(1<=j< i)(其中w[i]表示区间i的价值,并且满足两区间不重叠,具体是:a[j].r+R<=a[i].l)

#include<bits/stdc++.h>
using namespace std;
struct wl{
    int l,r,w;
}a[1001];
int n,m,R;
int dp[1001];
bool cmp(wl x,wl y){
    return x.l<y.l;
}
int main(){
    cin>>n>>m>>R;
    for(int i=1;i<=m;i++){
        scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].w);
    }
    sort(a+1,a+m+1,cmp);
    int ans=0;
    for(int i=1;i<=m;i++){
        dp[i]=a[i].w;
        for(int j=1;j<i;j++){
            if(a[j].r+R<=a[i].l){
                dp[i]=max(dp[i],dp[j]+a[i].w);
            }
        }
        ans=max(ans,dp[i]);
    }
    cout<<ans;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值