Ubuntu9.04下使用apt安装配置LAMP

在ubuntu里安装LAMP可以使用新立得来进行,具体的方法可以参看上一篇文章。按照文章的介绍,一般都没有问题。
但是有些时候,可能安装LAMP就不是很顺利,也有一些朋友希望通过apt来进行安装,本文介绍这些内容。

一、准备工作
如果之前系统里没有安装过LAMP,执行代码:
sudo apt-get update

如果之前系统里安装过LAMP 要保证系统里有关apache2,php5,mysql都彻底删除干净,在新立得软件包管理器里分别搜索php5,apache2,mysql把安装的软件包以及依赖包彻底删除。也可以用终端中执行代码:
sudo apt-get remove –purge apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libmysqlclient15off libnet-daemon-perl libplrpc-perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php5-common php5-mysql
sudo rm -R /etc/php5

做一些清理工作,请执行执行代码:
sudo apt-get autoremove
sudo apt-get autoclean

二、安装LAMP
需要执行的代码如下:
1、安装apache
sudo apt-get install apache2
2、安装php
sudo apt-get install php5
3、安装mysql
sudo apt-get install mysql-server libapache2-mod-auth-mysql php5-mysql

三、两个常见问题的解决
1.apache2: Could not determine the server’s fully qualified domain name, using 127.0.0.1 for ServerName
对apahce的配置文件进行修改:
sudo gedit /etc/apache2/conf.d/fqdn
如果不能够使用gedit,那么可以使用vim。
在这个文件中加入:
ServerName localhost

保存,退出。执行下面的命令:
echo “ServerName localhost” | sudo tee /etc/apache2/conf.d/fqdn
如果终端显示:
ServerName localhost
表明设置成功。

2.无法解析php文件,浏览器提示下载所要打开的php文件。
首先需要查看软件是否安装正确。
sudo apt-get install libapache2-mod-php5
sudo a2enmod php5
如果显示的结果是:
This module does not exist!
那就要彻底删除libapache2-mod-php5,然后重新安装它。
安装就是执行下面的代码:
sudo apt-get remove –purge libapache2-mod-php5
sudo apt-get install libapache2-mod-php5

安装完毕后,重启apache2。
sudo /etc/init.d/apache2 restart

清除浏览器缓存,然后输入http:localhost。(如果是Firefox浏览器,这一步就非常关键了。)

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值