1113 Integer Set Partition (25分)

测试地址:

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

【题意】

要求把一个集合分成两个不相交的集合,使得这两个集合的元素个数相差最小的前提下, 两个集合的总和之差最大

思路1

要使两个集合 S1,S2 的总和之差最大,就要使 S2 的总和尽可能大, S1 的总和尽可能小,那就把集合按从小到大排序,前 n/2 个数存放在 S1 中,后 n/2 或 n/2+1 个数存放在 S2中,所得总和之差 |S1 - S2| 就最大;(如果 n 为奇数,就把排序后在最中间那个数给集合 S2)

|n1 – n2| 就是 n % 2的结果,奇数为1,偶数为0。

【AC代码1】

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+7;
int a[maxn];
int main(){
	int n, sum1=0, sum2=0;
	cin >> n;
	for(int i = 0; i < n; i++)	cin >> a[i];
	sort(a, a+n);
	for(int i = 0; i < n/2; i++)	sum1 += a[i];
	for(int i = n/2; i < n; i++)	sum2 += a[i];
	cout << n%2 << " " << sum2-sum1;
	return 0;
}

【思路2】

先把集合内 n 个元素排序,计算前 n/2 个元素的总和,然后用总的总和 sum – 2 * halfsum 即为 |S1 – S2|。

|n1 – n2| 就是n % 2的结果,奇数为1,偶数为0。总和sum的值在输入时累加得到
 

【AC代码2】

#include<iostream>
#include<algorithm>
#include <vector> 
using namespace std; 
int main() {    
	int n, sum = 0, halfsum = 0;    
	scanf("%d", &n);    
	vector<int> v(n);    
	for(int i = 0; i < n; i++) {        
		scanf("%d", &v[i]);        
		sum += v[i];    
	}    
	sort(v.begin(), v.end());    
	for(int i = 0; i < n / 2; i++)        
		halfsum += v[i];    
	printf("%d %d", n % 2, sum - 2 * halfsum);    
	return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值