1075 PAT Judge (25分)

测试地址:

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

【题意】

第一行输入 n(参加 PAT 的总人数),k(PAT 中总问题数),m(提交的总次数)

第二行输入 k 个问题的满分

之后 m 行,输入考生 id,提交题目号,得分

输出时,输出参赛人中做过题的学生的排名,id,总成绩,K个问题的得分

没有通过编译器的分数为 0,但是没有提交过的分数为 “-”

按总成绩的先后输出,如果总成绩相同,按通过题数的降序来排序,如果通过题目也相同,则按 id 的升序来排序;

要注意排名的问题,如果总成绩相同,排名是相同的,应为 1 1 3,而不是 1 1 2;

【思路】

       结构体数组 num 中统计完整通过的题目个数,isshown 是用户有一题通过了编译器(不管得不得0分)的时候置为true。vector<int> score;记录每门课的最高分;


       因为没有通过编译器的分数为 0,但是没有提交过的分数为 “-”,所以把有一道题每次都是未通过编译器的那道题分数置为 -2。初始化数组分数为 -1,所以可以根据 -1 和 -2 判断当前分数是提交过了但没通过编译器器的,还是没提交过的题目


注意:因为后一个测试样例例是有一个人一开始得到了分数,后来提交了一次没有通过编译器的,所以要判断在分数每次更更新最大值之后 if(v[id].score[num] == -1),说明好成绩只是-1(也就是没通过编译器器或者没有提交过),这个时候再置v[id].score[num] = -2,否则会误操作把已经提交过的较高分数的人的成绩抹掉成了 -2

【AC代码】

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int n, k, m, id, p, score;
typedef struct{
	int rank, id, total=0;
	vector<int> score;
	int passnum = 0;
	bool isshown = false;
}num;
int cmp(num a, num b){
	if(a.total == b.total){
		if(a.passnum == b.passnum){
			return a.id < b.id;
		}
		return a.passnum > b.passnum;
	}
	return a.total > b.total;
}
int main(){
	cin >> n >> k >> m;
	vector<num> v(n+1);
	for(int i = 1; i <= n; i++){
		v[i].score.resize(k+1, -1);
	}
	vector<int> full(k+1);
	for(int i = 1; i <= k; i++){
		cin >> full[i];
	} 
	for(int i = 0; i < m; i++){
		cin >> id >> p >> score;
		v[id].id = id;
		v[id].score[p] = max(v[id].score[p], score);
		if(score != -1){
			v[id].isshown = true;
		}
		else if(v[id].score[p] == -1){
			v[id].score[p] = -2;
		}
	}
	for(int i = 1; i <= n; i++){
		for(int j = 1; j <= k; j++){
			if(v[i].score[j]!=-1 && v[i].score[j]!=-2){
				v[i].total += v[i].score[j];
			}
			if(v[i].score[j] == full[j]){
				v[i].passnum++;
			}
		}
	}
	sort(v.begin()+1, v.end(), cmp);
	for(int i = 1; i <= n; i++){
		v[i].rank = i;
		if(i!=1 && v[i].total == v[i-1].total){
			v[i].rank = v[i-1].rank;
		}
	}
	for(int i = 1; i <= n; i++){
		if(v[i].isshown == true){
			printf("%d %05d %d", v[i].rank, v[i].id, v[i].total);
			for(int j = 1; j <= k; j++){
				if(v[i].score[j]!=-1 && v[i].score[j]!=-2){
					printf(" %d", v[i].score[j]);
				}
				else if(v[i].score[j] == -1){
					printf(" -");
				}
				else{
					printf(" 0");
				}
			}
			printf("\n");
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值