24-语言入门-24-cigarettes

题目地址: http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=94

描述
Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them
one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?
输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14

124

代码:

#include <stdio.h>
//计算抽了多少支烟
//n-现有烟头数目
//k-k个烟头可以抽1支烟
static int calCigarettes(int n,int k);
int main()
{
     int readLen = 0;
     scanf("%d",&readLen);
     getchar();
     while(readLen > 0)
     {
          int n = 0;
          int k = 0;
          scanf("%d %d",&n,&k);
          getchar();
          printf("%d\n",calCigarettes(n,k));
          --readLen;
     }
     return 0;
}
//计算抽了多少支烟
//n-现有烟头数目
//k-k个烟头可以抽1支烟
static int calCigarettes(int n,int k)
{
     if(n<k || k<=1)
          return n;
     //已经抽了n支烟
     int result = n;
     do
     {
          //烟头中可以抽取k支烟
          int addCigaretCount = n / k;
          n = n % k + addCigaretCount;
          result += addCigaretCount;
     }while(n >= k);//剩余烟头和k对比,相等也需要进行
     return result;
}

做题时,漏掉了最初抽的香烟-n

另外判断条件也错了,漏掉了相等情况的判断

Image(2)

对于题目给定的测试数据测试没有问题,一直找不到问题出错在哪里,

后来借鉴 【16-语言入门-16-谁获得了最高奖学金】出错找错的经验

从输入数据入手,连续输入以下数据

2 3

3 3

4 3

5 3

6 3

7 3

8 3

9 3

当输入 9 3 时,发现少计算了1,最终确定了错误发生的地方。

 

问题虽小,但是花的时间找出错误却没少思前想后

从内心烦躁,到平静,到查看过往日志,想出找问题的方法,并最终在实践中找到答案,着实是中折磨,也是一种修炼。

 

另外不得不吐槽一下,南阳理工的ACM虽然中文居多,分类挺好,但是进去一次那是“蜀道难难于上青天呀”!

希望服务器哪天能够快一点。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值