PAT advanced 1001

A+B Format (20)

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

题目大意:
输入两个绝对值不大于10^6的数字,以三位一个逗号的格式规范地输出结果。

解题思路:
题目很简单,只有几个小细节要注意。1.是负数的话先输出 ‘-’ 然后转换成正数;2.考虑答案是 0 的情况;3.输出最后一位之后不要输出逗号.

注:觉得有什么问题请留言。

#include<iostream>
using namespace std;
int main()
{
    int a, b, sum, i;
    int ans[10];
    cin >> a >> b;
    sum = a + b;
    if (sum < 0)
    {
        cout << '-';
        sum = -sum;
    }
    if (sum == 0)
    {
        cout << '0';
        return 0;
    }
    ans[0] = 0;
    while (sum > 0)
    {
        ans[0]++;
        ans[ans[0]] = sum % 10;
        sum = sum / 10;
    }
    for (i = ans[0]; i > 0; i--)
    {
        cout << ans[i];
        if (i % 3 == 1 && i != 1)
            cout << ',';
    }
    //while (1)
    //  i = 0;
    return 0;
}

评测结果

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值