nyoj1278 zzuli1929 Prototypes analyze(河南省acm第九届省赛)

Prototypes analyze
时间限制:1000 ms | 内存限制:65535 KB
难度:2
描述
ALpha Ceiling Manufacturers (ACM) is analyzing the properties of its new series of Incredibly Collapse-Proof Ceilings (ICPCs). An ICPC consists of n layers of material, each with a different value of collapse resistance (measured as a positive integer). The analysis ACM wants to run will take the collapse-resistance values of the layers, store them in a binary search tree, and check whether the shape of this tree in any way correlates with the quality of the whole construction. Because, well, why should it not? To be precise, ACM takes the collapse-resistance values for the layers, ordered from the top layer to the bottom layer, and inserts them one-by-one into a tree. The rules for inserting a value v are:

• If the tree is empty, make v the root of the tree.

• If the tree is not empty, compare v with the root of the tree.

• If v is smaller, insert v into the left subtree of the root,

• otherwise insert v into the right subtree.

ACM has a set of ceiling prototypes it wants to analyze by trying to collapse them. It wants to take each group of ceiling prototypes that have trees of the same shape and analyze them together. For example , assume ACM is considering five ceiling prototypes with three layers each, as described by Sample Input 1 and shown in Figure C.1. Notice that the first prototype’s top layer has collapseresistance value 2, the middle layer has value 7, and the bottom layer has value 1. The second prototype has layers with collapse-resistance values of 3, 1, and 4 – and yet these two prototypes induce the same tree shape, so ACM will analyze them together. Given a set of prototypes, your task is to determine how many different tree shapes they induce.

这里写图片描述

输入
The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8).
Each test case specifies :
● Line 1: two integers n (1 ≤ n ≤ 50), which is the number of ceiling prototypes to analyze,
and k (1 ≤ k ≤ 20), which is the number of layers in each of the prototypes.
● The next n lines describe the ceiling prototypes. Each of these lines contains k distinct
integers ( between 1 and 1e6, inclusive ) , which are the collapse-resistance values of the
layers in a ceiling prototype, ordered from top to bottom.
输出
For each test case generate a single line containing a single integer that is the number of different tree
shapes.
样例输入
1
5 3
2 7 1
1 5 9
3 1 4
2 6 5
9 7 3
样例输出
4
题意就是根据输入给的数字,判断有多少种二叉树结构。
例如2 7 1,2首先放在根节点,然后7比2大放在根节点右边(右子树),1比7小 放在跟节点左边(左子树) 依次类推。如果是2 7 1 5,在放完1后 5比2大应该放在2的右边(右子树),可是2的右边已经有7,5和7比较,5比7小,放在7的左边。~

根据题意建二叉树即可。
难点在于如何分辨有多少子树。
在这里我通过遍历二叉树来分辨。如果某个节点有值置为1,否则置为0.最后将这些0 1 串放入set集合,输出set大小即可。

#include <stdio.h>
#include <set>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
int tree[1100000];
int pos;
//建二叉树 
void build(int root,int x)
{
    if(tree[root]==0)
    {
        //pos 表示当树的最远叶子节点的标号 
        pos=max(pos,root);
        tree[root]=x;
        return ;
    }
    else 
    {
        if(x<tree[root])
            build(root*2,x);
        else
            build(root*2+1,x);
    }
}
int main()
{
    int n,k,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&k);
        set<string>s;
        s.clear();
        while(n--)
        {
            memset(tree,0,sizeof(tree));
            pos=0;
            for(int i=0;i<k;i++)
            {
                int x;
                scanf("%d",&x);
                build(1,x);
            }
        //  printf("pos=%d\n",pos);
            string temp="";
            for(int i=1;i<=pos;i++)
            {
                if(tree[i]) temp.append("1");
                else temp.append("0");
            }
        //  cout<<temp<<endl;
            s.insert(temp);
        }
        printf("%d\n",s.size());
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值