poj~1068~Parencodings(数组模拟or重建括号)

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27909 Accepted: 16415

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:  
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).  
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).  

Following is an example of the above encodings:  
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.  

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
思路:理解题意就好写了,简单的模拟。


ACDAIMA:
#include <iostream>
#include <queue>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int t,n,a[1000],w[1000],p[1000];
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i = 1; i <= n; i++)
        {
            cin>>p[i];
        }
        //用a[i]记录每2个右括号之间(包括第一个右括号左边)的左括号个数.
        a[0] = p[1];
        for(int i = 1; i < n; i++)
            a[i] = p[i+1] - p[i];
        int j;
        for(int i = 1; i <= n; i++)
        {
            for(j = i - 1; j >= 0; j--)
            {
                if(a[j] > 0) //则一定有一个配对的括号
                {
                    a[j]--; //表示这一个括号匹配完毕,所以要减一
                    break; 
                }
            }
            w[i] = i - j; //储存答案;
        }

        for(int i = 1; i <= n; i++)
            cout<<w[i]<<" ";
        cout<<endl;

    }
    return 0;
}
思路二:先通过P序列重建括号序列。第i+p[i]位置一定是右括号,剩下的都是左括号。总长度为2*n。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
const int MAXN = 105;
int n, p[MAXN], w[MAXN];
char s[MAXN];
bool vis[MAXN];
int main()
{
    int T; scanf("%d", &T);
    while (T--)
    {
        memset(s, '#', sizeof(s));
        memset(vis, 0, sizeof(vis));
        memset(w, 0, sizeof(w));
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &p[i]);
            s[i + p[i]] = ')';
        }
        for (int i = 0; i < n*2; i++)
            if (s[i] == '#') s[i] = '(';
   
        int id = 0;
        for (int i = 0; i < n*2; i++)
        {
            if (s[i] == '(') continue;
            int cnt = 0;
            for (int j = i - 1; j >= 0; j--)
            {
                if (s[j] == '(')
                {
                    cnt++;
                    if (!vis[j])
                    {
                        vis[j] = true;
                        w[id++] = cnt;
                        break;
                    }
                }
            }
        }
        for (int i = 0; i < n; i++)
        {
            printf("%d", w[i]);
            if (i != n-1) printf(" ");
        }
        printf("\n");
    }
    return 0;
}
/*
20
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值