pat 1020

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
 
 
//用二叉树的两种遍历顺序建树的方法(确定了每次递归时左子树和右子树的边界)
#include <stdio.h>
#include <string.h>
#include <queue>
#include <vector>
using namespace std;

typedef struct Tree
{
	Tree *lchild;
	Tree *rchild;
	int data;
} Tree, *Llink;

Tree tree[50];

int loc = 0;

Tree* init()
{
	tree[loc].lchild = tree[loc].rchild = NULL;
	return &tree[loc++];
}

int n;
int postOrder[50], inOrder[50];
vector<int> vc; //存储层次遍历的结点
queue<Llink> Q; //层次遍历时存储指针
Tree *T = NULL;

Tree *build(int pos1, int pos2, int io1, int io2)
{
	int i;

	Tree *ret = init();
	ret->data = postOrder[pos2];

	for(i = io1; i < n; i++)
		if(postOrder[pos2] == inOrder[i])
			break;

	if(i != io2)
		ret->rchild = build(pos2 - io2 + i, pos2-1, i+1, io2);

	if(i != io1)
		ret->lchild = build(pos1, pos2 - io2 + i - 1, io1, i-1);

	return ret;
}

void levelTraversal()
{
	Q.push(T);
	vc.push_back(T->data);

	while(!Q.empty())
	{
		Llink top = Q.front();
		Q.pop();

		if(top->lchild != NULL)
		{
			Q.push(top->lchild);
			vc.push_back(top->lchild->data);
		}

		if(top->rchild != NULL)
		{
			Q.push(top->rchild);
			vc.push_back(top->rchild->data);
		}
	}
}

int main()
{
	int i;

	while(scanf("%d", &n) != EOF)
	{
		T = NULL;
		for(i = 0; i < n; i++)
			scanf("%d", &postOrder[i]);

		for(i = 0; i < n; i++)
			scanf("%d", &inOrder[i]);

		T = build(0, n-1, 0, n-1);

		levelTraversal();

		for(i = 0; i < vc.size(); i++)
		{
			if(i != vc.size() - 1)
				printf("%d ", vc[i]);
			else
				printf("%d\n", vc[i]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值