pat 1043

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
 
 
//题目不难就是麻烦
#include <stdio.h>

struct Tree
{
	Tree *lchild;
	Tree *rchild;
	int data;
} tree[1010];

int loc = 0, n, node[1010];
int peOd[1010], psOd[1010];
int count = 0;

Tree *creat()
{
	tree[loc].lchild = tree[loc].rchild = NULL;
	return &tree[loc++];
}

Tree *build(Tree *T, int data)
{
	if(T == NULL)
	{
		T = creat();
		T->data = data;
		return T;
	}
	else if(data >= T->data)
		T->rchild = build(T->rchild, data);
	else if(data < T->data)
		T->lchild = build(T->lchild, data);

	return T;

}

Tree *rbuild(Tree *T, int data)
{
	if(T == NULL)
	{
		T = creat();
		T->data = data;
		return T;
	}
	else if(data >= T->data)
		T->lchild = rbuild(T->lchild, data);
	else if(data < T->data)
		T->rchild = rbuild(T->rchild, data);

	return T;
}

void preOrder(Tree *T)
{
	if(T != NULL)
	{
		peOd[count++] = T->data;
		//printf("%d ", T->data);
		preOrder(T->lchild);
		preOrder(T->rchild);
	}
}

void postOrder(Tree *T)
{
	if(T != NULL)
	{
		postOrder(T->lchild);
		postOrder(T->rchild);
		psOd[count++] = T->data;
		//printf("**%d ", T->data);
	}
}
int main()
{
	int i, j;

	while(scanf("%d", &n) != EOF)
	{
		Tree *T = NULL;

		for(i = 1; i <= n; i++)
			scanf("%d", &node[i]);

		for(i = 1; i <= n; i++)
			T = build(T, node[i]); //建立了一颗二叉排序树

		//判断该二叉排序树的前序序列是否为给定的序列
		count = 1;
		preOrder(T);

		for(i = 1; i <= n; i++)
			if(peOd[i] != node[i])
				break;

		if(i > n)
		{
			printf("YES\n");
			count = 1;
			postOrder(T);
			for(i = 1; i < n; i++)
				printf("%d ", psOd[i]);
			printf("%d\n", psOd[n]);
			continue;
		}
		//判断二叉树的mirror
		T = NULL;
		for(i = 1; i <= n; i++)
			T = rbuild(T, node[i]);
	
		count = 1;
		preOrder(T);

		for(i = 1; i <= n; i++)
			if(peOd[i] != node[i])
				break;

		if(i > n)
		{
			printf("YES\n");
			count = 1;
			postOrder(T);
			for(i = 1; i < n; i++)
				printf("%d ", psOd[i]);
			printf("%d\n", psOd[n]);
			continue;
		}

		printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据引用中的说明,给定一个字符串"pat"和一个长度为104的字符串,我们需要将104个字符按照PATest的顺序重新排列,并忽略其他字符。根据引用中的代码,我们可以使用一个map来统计各个字符的出现次数。然后,我们按照PATest的顺序循环输出字符直到所有字符都被输出,每输出一个字符就将其对应的出现次数减少1。 具体步骤如下: 1. 创建一个map来统计字符出现次数。 2. 循环遍历104个字符,如果字符是"P"、"A"、"T"、"e"、"s"、"t"中的任意一个,就将其出现次数加1。 3. 创建一个字符串s1="PATest",用于按照PATest的顺序输出字符。 4. 进入一个循环,循环条件为flag等于1,表示还有字符需要输出。 5. 在循环中,遍历字符串s1,如果字符在map中的出现次数大于0,则将该字符输出,并将其出现次数减1。 6. 如果在循环中有字符被输出,则将flag设为1,表示还有字符需要输出。 7. 当循环结束后,所有字符都被输出,输出结果为PATest。 因此,根据给定的字符串"pat"和长度为104的字符串,输出应为PATest。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [PAT 1043 输出PATest](https://blog.csdn.net/qq_61117990/article/details/123307930)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [PAT 1043 输出PATest (c++)](https://blog.csdn.net/qq_42334822/article/details/122637564)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值