pat 1074

1074. Reversing Linked List (25)

时间限制
300 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, andNext is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000

99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include <stdio.h>
#include <string.h>

struct Node
{
	int next;
	int data;
	int cur;
} node[100010];

Node nd[100010]; //我靠,靠靠。刚开始的时候有一个测试点没过,耗费了半天找错误。最后竟然是把nd数组的大小写成了10010,中间少见了个0。。。

int start, n, k;

int main()
{
	int i, tmp, j;

	while(scanf("%d %d %d", &start, &n, &k) != EOF)
	{
		for(i = 1; i <= n; i++)
		{
			scanf("%d", &tmp);
			scanf("%d%d", &node[tmp].data, &node[tmp].next);
			node[tmp].cur = tmp;
		}

		tmp = start;
		i = 1;

		while(tmp != -1)
		{
			nd[i] = node[tmp];
			tmp = node[tmp].next;
			i++;
		}

		n = i - 1; //n是去除链表中多余的结点后的长度

		if(k > n) //如果要逆置的元素个数大于链表的长度
		{
			for(i = n; i >= 1; i--)
			{
				printf("%05d %d", nd[i].cur, nd[i].data);
				if(i != 1)
					printf(" %05d\n", nd[i-1].cur);
				else
					printf(" -1\n");
			}
			continue;
		}

		memset(node, -1, sizeof(node));

		int cnt = 1;
		i = 1;

		while(k * cnt <= n)
		{
			int end = k * cnt, begin = end - k + 1;
		
			for(; end >= begin; end--)
			{
				node[i].cur = nd[end].cur;
				node[i].data = nd[end].data;
				i++;
			}
			cnt++;
		}

		cnt--;

		for(j = cnt * k + 1; j <= n; j++)
			node[i++] = nd[j];

		for(j = 1; j < i; j++)
		{
			printf("%05d %d", node[j].cur, node[j].data);

			if(j < i-1)
				printf(" %05d\n", node[j+1].cur);
			else if(j == i-1)
				printf(" -1\n");
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值