pat 1102 Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

#include <iostream>
#include <string>
#include <vector>
#include <queue>
using namespace std;

struct  TreeNode
{
	int val;
	TreeNode *left;
	TreeNode *right;

} tree[15];

vector<int> level;
vector<int> in;

void level_order(TreeNode *root) {
	queue<TreeNode *> Q;

	Q.push(root);

	while(!Q.empty()) {
		TreeNode *node = Q.front();
		Q.pop();
		if(node != NULL) {
			level.push_back(node->val);
			Q.push(node->left);
			Q.push(node->right);
		}
	}
}

void in_order(TreeNode *node) {
	if(node != NULL) {
		in_order(node->left);
		in.push_back(node->val);
		in_order(node->right);
	}
}


int main() {
	int n;
	char ch1, ch2;
	int node[15], root = -1;

	cin >> n;

	for (int i = 0; i < n; ++i)
	{
		node[i] = 0;
	}

	for (int i = 0; i < n; ++i)
	{
		cin >> ch1 >> ch2;
		tree[i].val = i;

		if(ch1 >= '0' && ch1 <= '9') {
			node[ch1-'0'] = 1;
			
			tree[i].right = &(tree[ch1-'0']);
		} else {
			tree[i].right = NULL;
		}

		if(ch2 >= '0' && ch2 <= '9') {
			node[ch2-'0'] = 1;
			tree[i].left = &(tree[ch2-'0']);
		} else {
			tree[i].left = NULL;
		}

	}

	for (int i = 0; i < n; ++i)
	{
		if(node[i] == 0) {
			root = i;
			break;
		}
		
	}
	
	level_order(&(tree[root]));
	in_order(&(tree[root]));
	
	for (int i = 0; i < level.size(); ++i)
	{
		if(i == 0) {
			cout << level[i];
		} else {
			cout << " " << level[i];
		}
	}

	cout << endl;

	for (int i = 0; i < in.size(); ++i)
	{
		if(i == 0) {
			cout << in[i];
		} else {
			cout << " " << in[i];
		}
	}

	cout << endl;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值