1012. Joseph

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source

Central Europe 1995

涉及到的问题:
1. 剪枝
指对于一些用穷举法搜索的问题,添加搜索终止的条件或者减少搜索的范围,以减小运算量的方法。常见的如对称型问题化简等等。
本题中应该注意一个地方:第一次处决好人的情况显然应该跳过。例如有好人坏人各k个,取n为1到k显然不行,同理n为(2k+1)到(2k+k)显然不行。用穷举法时应该直接跳过这些值不做计算,直观看可以节省一半的计算量。
2. 动态规划
简单说,把一个大的动作划分为若干个具有重复性小动作的结果。本题中,很明显下一个处决的人的位置可以通过上一个位置得到。递推公式可以加快搜索速度。

参考文章:
1. 剪枝:
2. 动态规划:http://zh.wikipedia.org/wiki/%E5%8A%A8%E6%80%81%E8%A7%84%E5%88%92
3. 囧色夫问题的完整解答:http://zh.wikipedia.org/wiki/%E7%BA%A6%E7%91%9F%E5%A4%AB%E6%96%AF%E9%97%AE%E9%A2%98

我的源代码:
#include <stdio.h>
#include <string.h>

int main()
{
    int result[13];
    int k = 0;
    for (k = 1; k <= 13; ++k)
    {
	int m = k + 1;
	while (1)
	{
	    int i = 0;
	    int pos = 0;
	    for (; i < k; i++)
	    {
		pos = (m + pos - 1) % (2 * k - i);  //next guy to be killed
		if (pos < k)
		{
		    break;
		}
	    }
	    if (k == i)  //k bad guys were killed
	    {
		result[k - 1] = m;
		break;
	    }
	    else
	    {
		++m;
		if (m % (2 * k) == 1)  //skip good guys
		{
		    m += k;
		}
	    }
	}
    }

    while (1)
    {
  	if (scanf("%d", &k) != 1)
	{
	    return 0;
	}

	if (0 == k)
	{
	    return 0;
	}

	printf("%d\n", result[k - 1]);
    }   

    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值