杭电ACM 1200

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6297    Accepted Submission(s): 4322


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
 
解题思路用一个二维字符数组保存字符串的内容,并且当奇数行时是按顺序保存n个字符,若为偶数行时是按逆序保存n个字符,最后再一列一列的输出来

以下是我的代码:

#include<iostream>
#include<string>
using namespace std;
int main()
{
    string str;
	int i,j,n,k,size;
	char c[100][100];
	while(cin>>n && n != 0)
	{
		i = 0;
		getchar();
		getline(cin,str);
		size = str.size();

		for(k = 0;k < size;)
		{ 
          if(i % 2 == 0) 
		  {
			  for(j = 0;j < n;j++,k++)
			  {
				  c[i][j] = str[k];
			  } 
		  }
		  else
		  {
			  for(j = n-1;j >= 0;j--,k++)
			  {
				  c[i][j] = str[k];
			  }
		  }
		  i++;
		}

	    for(j = 0;j < n;j++)
		{
			for(i = 0;i < size/n;i++)
			{
				cout<<c[i][j];
			}			
		}
		cout<<endl;
	}
	return 0;
}

注意如果用了getline输入,记得加上getchar(),如果少了它你会发现输出的字符向后移了一位。当时我看到它后移了一位我就把输出也改后了一位,结果还是WA了,添上getchar()就AC了。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值