Game Prediction

Game Prediction

Problem Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

最少赢得次数,

#include<stdio.h>
#include<malloc.h>
int main(){
	int m,n;
	int time=0;
	scanf("%d %d",&m,&n);
	while(m!=0&&n!=0){
		int *p =(int *)malloc(n*sizeof(int));  //储存自己的牌
		for(int i=0;i<n;i++)
		scanf("%d",&p[i]);
		int *p2 =(int *)malloc(n*m*sizeof(int)); //储存所有的牌
		int max=n*m;
		for(int i=0;i<n*m;i++){
			p2[i]=max;
			max--;
		}
		for(int i=0;i<n;i++){                   //将牌堆中自己拿走的牌变为0
			for(int j=0;j<n*m;j++)
			{
				if(p[i]==p2[j])
				{
				p2[j]=0;
				break;
			    }
			}
		}
		for(int i=0;i<n-1;i++){                //将自己的牌排序
			for(int j=i+1;j<n;j++){
				if(p[i]<p[j])
				{
					int c=p[i];
					p[i]=p[j];
					p[j]=c;
				}
			}
		}
		int j=0; 
		int win=0;                             //统计赢得次数
	    j=0;
		for(int i=0;i<n;i++){                 //牌堆中 遇到自己拿走的牌就直接++
			while(p2[j]==0)                    //如果自己的牌比牌堆最大的还大,则获胜次数+1
			j++;                               //如果比自己牌比牌堆最大的小,则牌堆这张牌被用掉,自己那个比较大的牌
			if(p[i]>p2[j])                      //也被用掉。
			win++;
			else
			j++; 
		}
		printf("case %d:%d",++time,win);
		scanf("%d %d",&m,&n);
	}
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值