hdu1856 More is better(并查集 )

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 15426    Accepted Submission(s): 5662


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
#include<stdio.h>
#define N 10000001
int p[N];
int num[N];
void Init()
{
	int i;
	for(i=1;i<=N;i++)
	{
		p[i]=i;//初始化,一开始结点都是自己 
		num[i]=1;
	}
}
int findx(int x)//寻找根结点 
{
	return x==p[x]?x:p[x]=findx(p[x]);//一开始没有写成递归,超时了 
}
void fun(int x,int y)
{
	int fx=findx(x);
	int fy=findx(y);
	if(fx!=fy)
	{
		p[fy]=fx;
		num[fx]+=num[fy];//合并集合元素个数 ,
		//合并两个集合的时候要把一个集合中的元素都加到另一个集合代表中
	}
}
int main()
{
	int i,n,A,B;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		{
			printf("1\n");
 			continue;
		}
	    Init(); 
	    int t;
	    int max=1;//当所有的人都不认识,那么就剩一个人帮老师了
		for(i=1;i<=n;i++)
		{
			scanf("%d %d",&A,&B);
			/*if(A>t)
			t=A;
			if(B>t)
			t=B;*/
			fun(A,B);					
		}
		for(i=1;i<=N;i++)		
		{
			if(max<num[i])
			max=num[i];
		}
		printf("%d\n",max);
	}
	return 0;
}
//当所有的人都不认识,那么就剩一个人帮老师了 
//为当n为0是表示没有朋友关系,那么可以派出一个!o(╯□╰)o


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值