hdu1250Hat's Fibonacci(大数加法)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7938    Accepted Submission(s): 2585


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<stdio.h>
#include<string.h>
#define MAX 3000+3
char str1[MAX],str2[MAX],c[MAX];
void change(char str1[],char str2[],char sum[])
{
	int len1,len2,i,j,k,z;
	len1=strlen(str1)-1;
	len2=strlen(str2)-1;
	z=0;
	k=0;
	for(i=len1,j=len2;i>=0||j>=0;i--,j--)
	{
		if(i>=0)
			z+=str1[i]-'0';
		if(j>=0)
			z+=str2[j]-'0';
		c[k++]=z%10+'0';
		z=z/10;
	}
	if(z) c[k++]='1';
	i=0;
	for(--k;k>=0;k--)
	sum[i++]=c[k];
	sum[i]='\0';
}
int main()
{
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		char str1[MAX]="1",str2[MAX]="1",str3[MAX]="1",str4[MAX]="1";//相当于题目中的f(1)=1,f(2)=1,f(3)=1,f(4)=1; 
		char f[MAX],f1[MAX],sum1[MAX];
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		for(i=4;i<n;i++)
		{
			change(str1,str2,f);
			change(str3,str4,f1);
			change(f,f1,sum1);
			strcpy(str1,str2);
			strcpy(str2,str3);
			strcpy(str3,str4);
			strcpy(str4,sum1);
		}
		printf("%s\n",str4);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值