poj1562 Oil Deposits(DFS)

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13148 Accepted: 7166

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int m,n;
char map[105][105];
void dfs(int x,int y)
{//现在的位置是(x,y) 
	map[x][y]='*';//将现在的位置替换为.
	//循环遍历移动8个方向 
	for(int dx=-1;dx<=1;dx++)
	{//向x方向移动x,向y方向移动y,移动结果是(nx,ny) 
		for(int dy=-1;dy<=1;dy++)
		{
			int nx=x+dx;
			int ny=dy+y;
			//判断(nx,ny)是否在院子里,以及是否有积水 
			if(nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]=='@')
			dfs(nx,ny);
		}
	}
}
void solve()
{
	int i,j;
	int ans=0;
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		{
			if(map[i][j]=='@')
			{//从有水的地方开始dfs 
				dfs(i,j);
				ans++;
			}
		}
	}
	printf("%d\n",ans);
}
int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF&&(m||n))
	{
		/*getchar();//在这多加了一个getchar(),让我WA了一上午!!! 
		for(i=1;i<=n;i++)
		{
			//getchar();
			for(j=1;j<=m;j++)
			{
				scanf("%c",&map[i][j]);
			}
		}*/
		for(i=0;i<n;i++)
		scanf("%s",map[i]);
		solve();
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值