POJ2484 A Funny Game (典型博弈论)



Description

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10 6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

Sample Input

1
2
3
0

Sample Output

Alice
Alice
Bob
 
 
题目大意(很好的阅读理解):一堆硬币,呈环形放在桌子上,Alice先取,Bob后取,每次要么取一颗要么取两颗,不能不取,且取两颗的话只能取相邻的两颗,“相邻”的含义是:中间不能有别的硬币或取走的硬币留下的空位。取走最后一个硬币的人获胜。输入硬币数,输出谁会获胜。(两人都够聪明)
最近刚还离散数学学到了这里,其实,当硬币数目大于二的时候,后者是有必胜策略的,他只需要和先手对称着取就可以了。(不信的话自己模拟)
代码:
#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n;
    while(1)
    {
        scanf("%d",&n);
        if (n==0)
        {
            break;
        }
        else
        {
            if (n>=3)
            {
                printf("Bob\n");
            }
            else
            {
                printf("Alice\n");
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值