POJ2387 Til the Cows Come Home(dijkstra求图论最短路)



Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90
 
 
题目大意:输入点的个数N和边的个数T,给出所有边,三个数字分别表示边的左右端点,和路径的长度,求点N到点1的最短路。(虽然题目中没有提到,但POJ中的discuss已经证明了有可能会有重边的现象,这时候我们要以最短的那条边为准)
一道纯粹的dijkstra算法求图论最短路的题,基本思路与prim求解最小生成树有极大的相似性,每次都把离已经搜过的点最近的点加进来,然后更新其他点的距离,直到找到目标点为止。
另外还要注意N与T的输入顺序,WA了两发。
 
 
#include <iostream>
#include <stdio.h>

using namespace std;

int ans,n,t,i,j,dis[2002][2002],u,mind,b,e,d,low[2002]={0};
bool vis[2002]={false};

int main()
{
    for (i=0;i<=2000;i++)
    {
        for (j=0;j<=2000;j++)
        {
            dis[i][j]=10000000;
        }
    }
    scanf("%d%d",&t,&n);
    ans=0;
    for (i=1;i<=t;i++)
    {
        scanf("%d%d%d",&b,&e,&d);
        if (d<dis[b][e])
        {
            dis[b][e]=d;
            dis[e][b]=d;
        }
    }
    for (i=1;i<=n;i++)
    {
        low[i]=dis[1][i];
    }
    vis[1]=true;
    for (i=2;i<=n;i++)
    {
        mind=999999;
        for (j=1;j<=n;j++)
        {
            if (vis[j]==false&&mind>low[j])
            {
                mind=low[j];
                u=j;
            }
        }
        vis[u]=true;
        ans=low[u];
        if (vis[n]==true)
        {
            break;
        }
        for (j=0;j<=n;j++)
        {
            if (vis[j]==false&&low[j]>dis[u][j]+mind)
            {
                low[j]=dis[u][j]+mind;
            }
        }
    }
    printf("%d",ans);
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值