洛谷 P1339 [USACO09OCT]热浪Heat Wave

2 篇文章 0 订阅
1 篇文章 0 订阅

题目描述

The good folks in Texas are having a heatwave this summer. Their Texas Longhorn cows make for good eating but are not so adept at creating creamy delicious dairy products. Farmer John is leading the charge to deliver plenty of ice cold nutritious milk to Texas so the Texans will not suffer the heat too much.

FJ has studied the routes that can be used to move milk from Wisconsin to Texas. These routes have a total of T (1 <= T <= 2,500) towns conveniently numbered 1..T along the way (including the starting and ending towns). Each town (except the source and destination towns) is connected to at least two other towns by bidirectional roads that have some cost of traversal (owing to gasoline consumption, tolls, etc.). Consider this map of seven towns; town 5 is the

source of the milk and town 4 is its destination (bracketed integers represent costs to traverse the route):

                          [1]----1---[3]-
                         /               \
                  [3]---6---[4]---3--[3]--4
                 /               /       /|
                5         --[3]--  --[2]- |
                 \       /        /       |
                  [5]---7---[2]--2---[3]---
                        |       /
                       [1]------

Traversing 5-6-3-4 requires spending 3 (5->6) + 4 (6->3) + 3 (3->4) = 10 total expenses.

Given a map of all the C (1 <= C <= 6,200) connections (described as two endpoints R1i and R2i (1 <= R1i <= T; 1 <= R2i <= T) and costs (1 <= Ci <= 1,000), find the smallest total expense to traverse from the starting town Ts (1 <= Ts <= T) to the destination town Te (1 <= Te <= T).

德克萨斯纯朴的民眾们这个夏天正在遭受巨大的热浪!!!他们的德克萨斯长角牛吃起来不错,可是他们并不是很擅长生產富含奶油的乳製品。Farmer John此时以先天下之忧而忧,后天下之乐而乐的精神,身先士卒地承担起向德克萨斯运送大量的营养冰凉的牛奶的重任,以减轻德克萨斯人忍受酷暑的痛苦。

FJ已经研究过可以把牛奶从威斯康星运送到德克萨斯州的路线。这些路线包括起始点和终点先一共经过T (1 <= T <= 2,500)个城镇,方便地标号為1到T。除了起点和终点外地每个城镇由两条双向道路连向至少两个其它地城镇。每条道路有一个通过费用(包括油费,过路费等等)。

给定一个地图,包含C (1 <= C <= 6,200)条直接连接2个城镇的道路。每条道路由道路的起点Rs,终点Re (1 <= Rs <= T; 1 <= Re <= T),和花费(1 <= Ci <= 1,000)组成。求从起始的城镇Ts (1 <= Ts <= T)到终点的城镇Te(1 <= Te <= T)最小的总费用。

输入输出格式

输入格式:
第一行: 4个由空格隔开的整数: T, C, Ts, Te

第2到第C+1行: 第i+1行描述第i条道路。有3个由空格隔开的整数: Rs, Re和Ci

输出格式:
一个单独的整数表示从Ts到Te的最小总费用。数据保证至少存在一条道路。

输入输出样例

输入样例#1:
7 11 5 4
2 4 2
1 4 3
7 2 2
3 4 3
5 7 5
7 3 3
6 1 1
6 3 4
2 4 3
5 6 3
7 2 1
输出样例#1:
7
说明

【样例说明】

5->6->1->4 (3 + 1 + 3)

分析

最模板的最短路,只是好久没打最短路,连一下而已。。

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cstring>
#define inf 0x3f
#define N 10000
using namespace std;

int n,m,s,x,y,z,w;
int d[N],v[N],last[N],head[N];
int cnt=0;
struct edge{int to,next,len,f;}e[N];

    queue<int> p;    

void spfa(int s)
{
    memset(d,inf,sizeof(d));
    memset(v,0,sizeof(v));
    d[s]=0;
    v[s]=1;
    p.push(s);
    while (!p.empty())
    {
        int u=p.front();
        p.pop();
        for (int i=last[u];i;i=e[i].next)
            if (d[u]+e[i].len<d[e[i].to])
            {
                d[e[i].to]=d[u]+e[i].len;
                if (!v[e[i].to])
                {
                    v[e[i].to]=1;
                    p.push(e[i].to);
                }
            }
        v[u]=0;
    }
}

void add(int u,int v,int len)
{
    e[++cnt].to=v;e[cnt].len=len;e[cnt].next=last[u];last[u]=cnt;
    e[++cnt].to=u;e[cnt].len=len;e[cnt].next=last[v];last[v]=cnt;
}

int main()                                         
{                                                    
    scanf("%d%d%d%d" ,&n,&m,&s,&w);                             
    for (int i=1;i<=m;i++)                                  
    {                                                      
        scanf("%d%d%d" ,&x,&y,&z);                             
        add(x,y,z);                                            
    }                                                   
    spfa(s);
    printf("%d" ,d[w]);
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值