HDU 2594 Simpsons’ Hidden Talents(KMP理解应用)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1658    Accepted Submission(s): 605


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
 

Source
 

Recommend
lcy
 
首先想说的是这个题目和上一篇一样
不要要注意的是求next 的next时候直到next比两个串长度都小的时候为止

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
char str[110000];
int next[110000];
int get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    while(str[i])
    {
        if(j==-1 || str[i]==str[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
    return 0;
}
int main()
{
    int len1,len2,i,j,k,len;
    while(scanf("%s",str)!=EOF)
    {
        len1=strlen(str);
        scanf("%s",str+len1);
        len2=strlen(str+len1);
        get_next();
        len=len1+len2;
        while(1)
        {
            if(next[len] <= len1 && next[len] <= len2)
            break;
            else
            len=next[len];
        }
        if(next[len]==0 || next[len]==-1)
        printf("0\n");
        else
        {
            for(i=0;i<next[len];i++)
            printf("%c",str[i]);
            printf(" %d",next[len]);
            printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值