HUST 1630 largest rectangle(思维题)

largest rectangle

Time Limit: 1 Sec   Memory Limit: 128 MB
Submissions: 11   Solved: 4

Description

Given n positive integers representing the histogram's bar height where the width of each bar is 1, find the area of largest rectangle in the histogram.

Above is a histogram where width of each bar is 1, given height =[2,1,5,6,2,3].

The largest rectangle is shown in the shaded area, which has area = 10 unit.

Input

  The first line of the input file contains an integer T (T<=100) specifying the number of test cases.
Each test case begins with a line containing an integer N (1<=N<=100000),The following N-1 lines each contain a integer A[i](1<=A[i]<=10000).

Output

 For each query, output a single line containing largest area. 

Sample Input

2
6
2
1
5
6
2
3
10
1
2
3
4
5
6
7
9
10
8

Sample Output

10
30

HINT

Source

The 8th(2013) ACM Programming Contest of HUST



直接枚举最低点,分别枚举最低点的位置,也就是以每一个柱子为最低点进行枚举,算左边有多少高于等于它的,右边同理

计算的时候利用上一次的结果进行跳转,接近O(n)

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn = 110000;
int rec[maxn],n;
int l[maxn],r[maxn];
int main(){
    int i,j,k,t,now,ans;
    scanf("%d",&t);
    while(t--){
        ans=-1;
        scanf("%d",&n);
        for(i=1;i<=n;i++) scanf("%d",&rec[i]);
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        for(i=2;i<=n;i++){
            now=i-1;
            while(now>0 && rec[i]<=rec[now]){
                l[i]+=l[now]+1;
                now-=l[now];
                now--;
            }
        }
        for(i=n-1;i>0;i--){
            now=i+1;
            while(now<=n && rec[i]<=rec[now]){
                r[i]+=r[now]+1;
                now+=r[now];
                now++;
            }
        }
        for(i=1;i<=n;i++)
        ans=max(ans,(l[i]+r[i]+1)*rec[i]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值