POJ 2420 A Star not a Tree?(计算几何 多边形的费马点 模拟退火)

A Star not a Tree?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2991 Accepted: 1533

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source



这个题目也是wa的我好伤心啊,原因就是模拟退火的步长和精度没控制好,尝试好多次才AC

不过觉得这个题目用到的模拟退火的思想很好,可以设置精度让我们的结果无限接近真正的答案

思想就是这样,开始选择一个初始点作为开始,选择一个步长度,然后走四个方向,选择一个

离正确答案最近的点,同时步长减半,接着模拟,直到步长小到一定程度就好了!

这个思想很精妙,也容易想到和实现,不过没有OJ测试精度不好保证啊!

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
using namespace std;
#define inf 1e-5
struct point
{
double x;
double y;
}po[150];
int n;
double dis(point &a,point &b)
{
return sqrt((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y));
}
int find_ans()
{
point pp,ppp;
point rec;
pp=po[0];
double step=1000000;
int i,j,k;
double d=0;
double ans;
for(i=0;i<n;i++)
ans+=dis(pp,po[i]);
rec=pp;
while(step > 0.2)
{
pp=rec;
d=0;
ppp=pp;
ppp.x+=step;
for(i=0;i<n;i++)
{
d+=dis(ppp,po[i]);
}
if(d < ans)
{
ans=d;
rec=ppp;
}
ppp=pp;
d=0;
ppp.x-=step;
for(i=0;i<n;i++)
{
d+=dis(ppp,po[i]);
}
if(d < ans)
{
ans=d;
rec=ppp;
}
ppp=pp;
d=0;
ppp.y-=step;
for(i=0;i<n;i++)
{
d+=dis(ppp,po[i]);
}
if(d < ans)
{
ans=d;
rec=ppp;
}
ppp=pp;
d=0;
ppp.y+=step;
for(i=0;i<n;i++)
{
d+=dis(ppp,po[i]);
}
if(d < ans)
{
ans=d;
rec=ppp;
}
step/=2;
}
if(ans-int(ans) >=0.5)
printf("%d\n",int(ans)+1);
else
printf("%d\n",int(ans));
return 0;
}
int main()
{
int i,j,k;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%lf%lf",&po[i].x,&po[i].y);
find_ans();
}
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值