HDU 3123 GCC(数学)

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3190    Accepted Submission(s): 1004


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

Sample Input
  
  
1 10 861017
 

Sample Output
  
  
593846
 

Source
 

Recommend
lcy
 
这个题目又悲催了几次,命名按照我的计算是不会超时的,但是交上去老是超时,原来是longlong的问题,哎
后来想改成__int64无奈linux下G++不支持__int64我也没管直接在代码上替换,然后提交,果然0msAC
这个数学题目其实还是比较简单的分析如下:

1.这个题目给的数据很吓人,10^100还是阶乘,难道还用大数取模? 都不用,因为后面说了对N!%M,那么M的最大为一百万
那么如若N>M N直接就等于M,后面全部是0
2.第二是不是每次要求新的阶乘呢? 当然不是,在上一次的基础上迭代一下就OK 了,所以这个题目就没什么难度了!

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
__int64 Max;
__int64 ans;
__int64 futher,num,mod;
__int64 i,j,k;
char str[200];
while(t--)
{
scanf("%s",str);
cin>>mod;
if(strlen(str) >= 7)
num=1000000;
else
sscanf(str,"%I64d",&num);
if(num > mod)
num=mod;
futher=1;
ans=1;
for(i=1;i<=num;i++)
{
futher=(futher*i)%mod;
if(futher == 0)
break;
ans+=futher;
}
cout<<ans%mod<<endl;
}
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值