(hdu3123)GCC(观察数据范围)

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 5137 Accepted Submission(s): 1714

Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means “the product of the integers from 1 to n”. For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + … + n!)%m

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + … + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input
1
10 861017

Sample Output
593846

Source
2009 Asia Wuhan Regional Contest Online

题意:给定两个数n,m(0 <= n < 10^100 (without leading zero))(0 < m < 1000000),求(0! + 1! + 2! + 3! + 4! + … + n!)%m.
分析:注意到本题n的长度最大是100,肯定不能直接输入,转为字符串输入,然后不能直接模拟,会TLE,注意m的范围最大为10^6,当n的长度大于6时,n!%m==0,这里n取m,就不用算后面的;所以这里判断一下,然后要注意字符串转化为数字时,要用long long,防止n!计算的过程溢出!!!

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long LL;
int main()
{
    int t,m;
    scanf("%d",&t);
    while(t--)
    {
        char str[105];
        scanf("%s%d",str,&m);
        int len=strlen(str);
        LL n,tmp;
        if(len>=7) n=m;
        else
        {
            tmp=0;
            for(int i=0; i<len; i++)
                tmp=tmp*10+str[i]-'0';
            n=tmp;
        }
        LL ans=0;
        tmp=1;
        for(int i=1; i<=n; i++)
        {
            tmp=(tmp*i)%m;
            ans=(ans+tmp)%m;
        }
        printf("%lld\n",(ans+1)%m);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值