HDU 4617 Weapon(立体计算几何)

Weapon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 144    Accepted Submission(s): 112


Problem Description
  Doctor D. are researching for a horrific weapon. The muzzle of the weapon is a circle. When it fires, rays form a cylinder that runs through the circle verticality in both side. If one cylinder of rays touch another, there will be an horrific explosion. Originally, all circles can rotate easily. But for some unknown reasons they can not rotate any more. If these weapon can also make an explosion, then Doctor D. is lucky that he can also test the power of the weapon. If not, he would try to make an explosion by other means. One way is to find a medium to connect two cylinder. But he need to know the minimum length of medium he will prepare. When the medium connect the surface of the two cylinder, it may make an explosion.
 

Input
  The first line contains an integer T, indicating the number of testcases. For each testcase, the first line contains one integer N(1 < N < 30), the number of weapons. Each of the next 3N lines&#160; contains three float numbers. Every 3 lines represent one weapon. The first line represents the coordinates of center of the circle, and the second line and the third line represent two points in the circle which surrounds the center. It is supposed that these three points are not in one straight line. All float numbers are between -1000000 to 1000000.
 

Output
  For each testcase, if there are two cylinder can touch each other, then output 'Lucky', otherwise output then minimum distance of any two cylinders, rounded to two decimals, where distance of two cylinders is the minimum distance of any two point in the surface of two cylinders.
 

Sample Input
  
  
3 3 0 0 0 1 0 0 0 0 1 5 2 2 5 3 2 5 2 3 10 22 -2 11 22 -1 11 22 -3 3 0 0 0 1 0 1.5 1 0 -1.5 112 115 109 114 112 110 109 114 111 -110 -121 -130 -115 -129 -140 -104 -114 -119.801961 3 0 0 0 1 0 1.5 1 0 -1.5 112 115 109 114 112 110 109 114 111 -110 -121 -130 -120 -137 -150 -98 -107 -109.603922
 

Sample Output
  
  
Lucky 2.32 Lucky
 

Source
 

Recommend
zhuyuanchen520
 
比赛时发现是立体几何,没动手,后来发现是很简单的水题,看AC率那么高就知道了,只要下的了手就能过!

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <cmath>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define inf 1e8
#define zero(x) (((x)>0?(x):-(X))<eps)
struct point3
{
    double x;
    double y;
    double z;
}temp,temp1,temp3;
struct line3
{
    point3 a;
    point3 b;
}fa[300];
struct plane3
{
    point3 a;
    point3 b;
    point3 c;
    double r;
}po[100];
point3 xmult(point3 u,point3 v)
{
    point3 ret;
    ret.x=u.y*v.z-v.y*u.z;
    ret.y=u.z*v.x-u.x*v.z;
    ret.z=u.x*v.y-u.y*v.x;
    return ret;
}
double dis(point3 a,point3 b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)+(a.z-b.z)*(a.z-b.z));
}
double vlen(point3 p)
{
    return sqrt(p.x*p.x+p.y*p.y+p.z*p.z);
}
double dmult(point3 u,point3 v)
{
    return u.x*v.x+u.y*v.y+u.z*v.z;
}
point3 subt(point3 u,point3 v)
{
    point3 ret;
    ret.x=u.x-v.x;
    ret.y=u.y-v.y;
    ret.z=u.z-v.z;
    return ret;
}
double linetoline(line3 u,line3 v)
{
    point3 n=xmult(subt(u.a,u.b),subt(v.a,v.b));
    return fabs(dmult(subt(u.a,v.a),n))/vlen(n);
}
int main()
{
    int t;
    int n,j,i;
    scanf("%d",&t);
    double min_ans;
    double re_dis;
    bool flag;
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf%lf%lf%lf%lf%lf%lf%lf",&po[i].a.x,&po[i].a.y,&po[i].a.z,&po[i].b.x,&po[i].b.y,&po[i].b.z,&po[i].c.x,&po[i].c.y,&po[i].c.z);
            temp.x=po[i].c.x-po[i].a.x;
            temp.y=po[i].c.y-po[i].a.y;
            temp.z=po[i].c.z-po[i].a.z;
            temp1.x=po[i].b.x-po[i].a.x;
            temp1.y=po[i].b.y-po[i].a.y;
            temp1.z=po[i].b.z-po[i].a.z;
            temp3=xmult(temp,temp1);
            fa[i].a=po[i].a;
            fa[i].b.x=po[i].a.x+temp3.x;
            fa[i].b.y=po[i].a.y+temp3.y;
            fa[i].b.z=po[i].a.z+temp3.z;
            po[i].r=dis(po[i].a,po[i].b);
        }
        min_ans=inf;
        flag=false;
        for(i=0;i<n;i++)
        for(j=i+1;j<n;j++)
        {
            re_dis=linetoline(fa[i],fa[j]);
            if(re_dis<=po[i].r+po[j].r)
            i=n,j=n,flag=true;
            else
            if(min_ans > re_dis-po[i].r-po[j].r)
            min_ans=re_dis-po[i].r-po[j].r;
           // printf("%lf\n",re_dis);
        }
        if(flag==true)
        printf("Lucky\n");
        else
        printf("%.2lf\n",min_ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值