HDU 1789 Doing Homework again(贪心算法)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4511    Accepted Submission(s): 2645


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy
 
这个题目的贪心算法比较简单,也比较容易想到,就是按照扣除的分数从小到大排序
然后从头开始贪心的从每个位置的deadline向前寻找没有被占用的时间来做这门作业
这样贪心的保证时间尽量用靠后的,防止前面有的作业没时间做,第二作业贪心的做
扣分大的,这就是为什么排序按照扣的分数从大到小的原因


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct point
{
    int re;
    int deadline;
}po[1500];
bool rec[1500];
int cmp(const void *a,const void *b)
{
    return (*(point*)a).re < (*(point*)b).re ? 1 : -1;
}
int main()
{
    int t;
    int n,i,j;
    scanf("%d",&t);
    int ans;
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&po[i].deadline);
        for(i=0;i<n;i++)
        scanf("%d",&po[i].re);
        qsort(po,n,sizeof(po[0]),cmp);
        memset(rec,1,sizeof(rec));
        ans=0;
        for(i=0;i<n;i++)
        {
            for(j=po[i].deadline;j>=1;j--)
            if(rec[j])
            { rec[j]=false;break;}
            if(j==0)
            ans+=po[i].re;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值