POJ 3261 Milk Patterns(后缀数组 重复出现K次字串的长度)

Milk Patterns
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7956 Accepted: 3610
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source


这个题目和上一个题目基本类似,上一个题目是要求求一个最长不重复字串,这个题目要求的是求至少重复K次的一个字串的最长长度

思想和上一个题目的思想基本类似,同样是二分同样是height区间分组,上一个题目在给区间分组的时候是按照height的值来分组,这个题目

也是,不过不同的是上一个题目要求记录出的是一个分组好了的区间的一个最左边和最右边方便判断是否重复,这个记录区间最大的长度

这样就能保证最大出现的次数,本质上课上面那个题目是一样的,二分分组

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define maxn 1021000
#define ws ws1
int wa[maxn],wb[maxn],wv[maxn],ws[maxn];
int cmp(int *r,int a,int b,int l)
{return r[a]==r[b]&&r[a+l]==r[b+l];}
void da(int *r,int *sa,int n,int m)
{
int i,j,p,*x=wa,*y=wb,*t;
for(i=0;i<m;i++) ws[i]=0;
for(i=0;i<n;i++) ws[x[i]=r[i]]++;
for(i=1;i<m;i++) ws[i]+=ws[i-1];
for(i=n-1;i>=0;i--) sa[--ws[x[i]]]=i;
for(j=1,p=1;p<n;j*=2,m=p)
{
for(p=0,i=n-j;i<n;i++) y[p++]=i;
for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
for(i=0;i<n;i++) wv[i]=x[y[i]];
for(i=0;i<m;i++) ws[i]=0;
for(i=0;i<n;i++) ws[wv[i]]++;
for(i=1;i<m;i++) ws[i]+=ws[i-1];
for(i=n-1;i>=0;i--) sa[--ws[wv[i]]]=y[i];
for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
}
return;
}
int rank[maxn],height[maxn];
void calheight(int *r,int *sa,int n)
{
int i,j,k=0;
for(i=1;i<=n;i++) rank[sa[i]]=i;
for(i=0;i<n;height[rank[i++]]=k)
for(k?k--:0,j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
return;
}
int rec[maxn],sa[maxn];
int n,len;
bool check(int m)
{
    int count=0;
    for(int i=1;i<=n;i++)
    {
        if(height[i]<m)
        {
            count=0;
        }
        else
        {
            count++;
            if(count >= len-1)
            return true;
        }
    }
    return false;
}
int main()
{
    int i,j,k;
    int left,right;
    int mid;
    int answer;
    while(scanf("%d%d",&n,&len)!=EOF)
    {
     for(i=0;i<n;i++)
     scanf("%d",&rec[i]);
     rec[n]=0;
     da(rec,sa,n+1,1000011);//这里是n+1 因为看这个函数里面是 < n 的
     calheight(rec,sa,n);//注意这里面是 n 了因为看函数里面是 <=n 的,所以这里要注意
     /*for(i=0;i < n ;i++)
     printf("%d ",height[i]);
     printf("\n");*/
     if(!check(1))
     {
         printf("0\n");
         continue;
     }
     left=1;
     right=20000;
     answer=-1;
     while(left <= right)
     {
         mid=(left+right)>>1;
         if(check(mid))
         {
             answer=mid;
             left=mid+1;
         }
         else
         {
             right=mid-1;
         }
     }
     printf("%d\n",answer);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值