最全eclipse自由轻松来回切换项目的jdk版本的方法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/superit401/article/details/72847110

需求背景:有时候本地eclipse运行的项目所使用的jdk版本比Linux服务器高(低),需要调低(高)jdk版本。

此处以我把jdk版本从1.7切换到1.6为例:

所有需要在eclipse中设置的在此,分两部分设置:

部分一:设置eclipse工作空间的jdk版本,即eclipse中所有项目的编译运行的环境

1.Window—Preferences—Java—Compiler—右侧面板设置为1.6

2.Window—Preferences—Java—Installed JREs—右侧面板“Add”本地的1.6版本jdk路径,并勾上


继续...

部分二:设置你要改变jdk的项目jdk的版本

3.右键项目(一般是cms-core分项目而不是cms-cms项目)—Properties(或项目右键—Build Path—Configure Build Path)—Java Build Path(右侧面板)—Libraries—(如果有JRE System Library [JavaSE-1.7]就点右侧的“Edit...”改为本地jdk1.6,如果是其他的jdk点“Remove”—Add Library...—选“JRE System Library”—Next—再改为本地的jdk1.6)—然后确保Libraries右侧的标签页“Order And Export”也出现JRE System Library [JavaSE-1.6]

4.与Java Build Path同页面的Java Compiler—右侧面板设置为1.6

5.Java Compiler同页面的Project Facets—右侧面板勾上Java,Version设为1.6



重要提示:有些同学本来项目是好的或者新导下来没问题的项目,在设置完jdk后项目就出错了,项目包名上有小红叉,但是就是没找到报错的文件,此时你就要看看是不是你的项目右键—build path设置页面有没有报错的,也要看看你的jdk版本这几步都设置到了么,少其中一步你的项目可能会报错出现小红叉而不会在具体的文件上出现小红叉,即使你的项目能跑,好像运行没什么问题,等到部署到服务器真正的版本问题出现,可能就找不到方向了。

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页