sgu 112 - a^b - b^a 大数

112. ab-ba

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

You are given natural numbers a and b. Find ab-ba.

Input

Input contains numbers a and b (1≤a,b≤100).

Output

Write answer to output.

Sample Input

2 3

Sample Output

-1


用scanner 会TLE

import java.io.*;
import java.math.BigInteger;


public class Main {
    public static void main(String args[]) throws IOException {
        StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
        PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));

        BigInteger a;
        BigInteger b;
        in.nextToken();
        int A=(int) in.nval;
        in.nextToken();
        int B=(int) in.nval;

        a=BigInteger.valueOf(A);
        b=BigInteger.valueOf(B);
        out.println(a.pow(B).subtract(b.pow(A)));
        out.flush();
    }

}

多组

while (in.nextToken() != StreamTokenizer.TT_EOF) 


我ruby A的姿势好丑,想学ruby啊太菜了

a=gets.split
x=a[0].to_i
y=a[1].to_i
print x**y-y**x




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值