sgu 133. Border 贪心

133. Border

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

Along the border between states A and B there are N defence outposts. For every outpost k, the interval [Ak,Bk] which is guarded by it is known. Because of financial reasons, the president of country A decided that some of the outposts should be abandoned. In fact, all the redundant outposts will be abandoned. An outpost i is redundant if there exists some outpost j such that Aj<Ai and Bi<Bj. Your task is to find the number of redundant outposts.

Input

The first line of the input will contain the integer number N (1<=N<=16 000). N lines will follow, each of them containing 2 integers: Ak and Bk (0<= Ak < Bk <= 2 000 000 000), separated by blanks. All the numbers Awill be different. All the numbers Bk will be different.

Output

You should print the number of redundant outposts.

Sample Input

5
0 10
2 9
3 8
1 15
6 11

Sample Output

3

删除多余区间


#include <bits/stdc++.h>

using namespace std;

struct node{
    int a;
    int b;
};

node no[16005];

bool cmp(node x,node y){
    if(x.a==y.a){
        return x.b>y.b;
    }
    return x.a<y.a;
}

void solve(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d%d",&no[i].a,&no[i].b);
    }
    sort(no,no+n,cmp);

//    for(int i=0;i<n;i++){
//        cout<<no[i].a<<" "<<no[i].b<<endl;
//    }
    int ans=0;
    int maxx=no[0].b;
    for(int i=1;i<n;i++){
        if(no[i].b>maxx){
            maxx=no[i].b;
        }
        else{
            ans++;
        }
    }
    printf("%d",ans);


}

int main(){
    solve();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值