HDU1026

        小雅文给推荐了一个杭电上的题,跳过题目看样例就知道是个BFS走地图……看到样例输出当时我就想骂人。先给出题目。

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11188    Accepted Submission(s): 3418
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 

Author
Ignatius.L

题目意思简介:勇者从左上角(0,0)出发,目标是右下角(n-1,m-1)。路上三种类型的点,'.'空地,数字表示有一个怪物,X就是障碍了。其中,怪物有血量1-9,表示勇者移动到这个格子之后还需要花费1-9的时间来击败怪物。距离‘.9.‘那么从左边的'.'出发,移动到第二格时间为1,打败怪物时间到10,然后再移动到右边时间为11.

求勇者从左上到右下的最短时间,并且输出路径。


算法 :BFS+优先队列

基本用不着分析可以得到的算法,就是coding的问题了,太久没写也是写的漏洞百出……自己一向在ACM比赛代码里不喜欢STL,于是果断手写了堆实现,还是挺简单的。之于输出格式,我想说!我讨厌输出路径!

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

const int N = 105;

int n, m;
char map[N][N];
bool visited[N][N];
int dir[4][2] = {{1, 0}, {0, 1}, {0, -1}, {-1, 0}}; //S E N W

int head, tail;

struct node
{
	int x, y;
	int v;
};
node que[N*N];
node road[N][N];
node out[N*N];
bool finded;

inline void init()
{
	for(int i = 0; i < n; i ++)
	{
		scanf("%s", map[i]);
	}
	memset(visited, false, sizeof( visited ));
}

void heap(int e, int dic)
{
	if( dic == 0 )
	{
		node temp = que[e];
		while( e*2+1 < tail )
		{
			int nexte = e * 2 + 1;
			if( que[nexte+1].v < que[nexte].v ) nexte ++;
			if( que[nexte].v < temp.v )
			{
				que[e] = que[nexte];
				e = nexte;
			}
			else break;
		}
		que[e] = temp;
	}
	else if ( dic == 1 )
	{
		node temp = que[e];
		while( e > 0 )
		{
			int nexte = (e-1) / 2;
			if( temp.v < que[nexte].v )
			{
				que[e] = que[nexte];
				e = nexte;
			}
			else break;
		}
		que[e] = temp;
	}
}

void output(int fx, int fy)
{
	int L = -1;
	node tp;
	tp.x = fx;
	tp.y = fy;
	while( tp.x != -1 )
	{
		out[++L] = tp;
		tp = road[tp.x][tp.y];
	}
	int time = 0;
	for(int i = L-1; i >= 0; i -- )
	{
		int x = out[i].x;
		int y = out[i].y;
		time ++;
		printf("%ds:(%d,%d)->(%d,%d)\n",time,out[i+1].x,out[i+1].y,x,y);
		if( map[x][y] != '.' )
		{
			int j;
			int cost = map[x][y] - '0';
			for(j = 1; j <= cost; j ++)
			{
				time ++;
				printf("%ds:FIGHT AT (%d,%d)\n", time, x, y);
			}
		}
	}
}


void expend(node now, node &next, int &tail)
{
	int x = next.x;
	int y = next.y;
	if( x < 0 || x >= n || y < 0 || y >= m ) return;
	if( map[x][y] == 'X' ) return;
	int value = 0;
	if( map[x][y] == '.' ) value ++;
	else value = map[x][y] - '0' + 1;
	next.v = now.v + value;
	if( !visited[x][y] )
	{
		road[x][y].x = now.x;
		road[x][y].y = now.y;
		visited[x][y] = true;
		if( x == n-1 && y == m-1 )
		{
			printf("It takes %d seconds to reach the target position, let me show you the way.\n", next.v);
			output(x, y);
			finded = true;
			return;
		}
		que[tail++] = next;
		heap(tail - 1, 1);
	}	
}

void bfs()
{
	head = 0, tail = 1;
	node now, end;
	now.x = 0;
	now.y = 0;
	now.v = 0;
	end.x = n -1;
	end.y = m -1;
	road[0][0].x = -1;
	road[0][0].y = -1;
	que[0] = now;
	visited[0][0] = true;
	finded = false;
	while( head < tail )
	{
		now = que[head];
		que[head] = que[tail-1];
		tail --;
		heap(0, 0);
		node next;
		for(int i = 0; i < 4; i ++)
		{
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			expend(now, next, tail);
		}
	}
	if( !finded )
	{
		puts("God please help our poor hero.");
	}
	puts("FINISH");
}

int main()
{
	while( scanf("%d %d", &n, &m) != EOF )
	{
		init();
		bfs();
	}
	return 0; 
} 



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值