poj 2192 Zipper

题目链接:http://poj.org/problem?id=2192

Zipper
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17549 Accepted: 6242
Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.
Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree
**Sample output**t

Data set 1: yes
Data set 2: yes
Data set 3: no

dp[ i ][ j ] 表示从s1中取第i个字符,从s2中取第j个字符来组成s3,0不可以组成,1可以组成。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
char s1[500],s2[500],s3[500];
int dp[500][500];
int main (void)
{
    int t;
    cin>>t;
    int ans=1;
    while(t--)
    {
        int le1,le2,le3;
        scanf("%s",s1+1);
        scanf("%s",s2+1);
        scanf("%s",s3+1);
        le1=strlen(s1+1);
        le2=strlen(s2+1);
        le3=strlen(s3+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=le1;i++)
        {
            if(s1[i]==s3[i])
                dp[i][0]=1;
            else
                break;
        }
        for(int i=1;i<=le2;i++)
        {
            if(s2[i]==s3[i])
            {
                dp[0][i]=1;
            }
            else 
                break;
        }
        int i,j;
        for( i=1;i<=le1;i++)
        {
            for( j=1;j<=le2;j++)
            {
                if(s3[i+j]==s1[i]&&dp[i-1][j])
                    dp[i][j]=1;
                if(s3[i+j]==s2[j]&&dp[i][j-1])
                    dp[i][j]=1;
            }
            //printf("%d %d %d\n",dp[i][j],i,j);
            //printf("%d_____%d %d\n",dp[le1][le2],le1,le2);
        }
        printf("Data set %d: ",ans++);
        if(dp[le1][le2])
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值