USACO-Longest Prefix

The structure of some biological objects is represented by the sequence of their constituents, where each part is denoted by an uppercase letter. Biologists are interested in decomposing a long sequence into shorter sequences called primitives.

We say that a sequence S can be composed from a given set of primitives P if there is a some sequence of (possibly repeated) primitives from the set whose concatenation equals S. Not necessarily all primitives need be present. For instance the sequence ABABACABAABcan be composed from the set of primitives

   {A, AB, BA, CA, BBC}

The first K characters of S are the prefix of S with length K. Write a program which accepts as input a set of primitives and a sequence of constituents and then computes the length of the longest prefix that can be composed from primitives.

PROGRAM NAME: prefix

INPUT FORMAT

First, the input file contains the list (length 1..200) of primitives (length 1..10) expressed as a series of space-separated strings of upper-case characters on one or more lines. The list of primitives is terminated by a line that contains nothing more than a period (`.’). No primitive appears twice in the list. Then, the input file contains a sequence S (length 1..200,000) expressed as one or more lines, none of which exceeds 76 letters in length. The “newlines” (line terminators) are not part of the string S.
SAMPLE INPUT (file prefix.in)

A AB BA CA BBC
.
ABABACABAABC
OUTPUT FORMAT

A single line containing an integer that is the length of the longest prefix that can be composed from the set P.
SAMPLE OUTPUT (file prefix.out)

11

题意:给一个集合和一串字母,问这串字母中由集合中子集构成的最大前缀和。

一步步的往后走就可以了。

代码:

/*
ID:iam666
PROG:prefix
LANG:C++
*/
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <vector>
using namespace std;
int tmp;
char a[210][20];
string str; 
int main (void)
{
freopen("prefix.in","r",stdin);
freopen("prefix.out","w",stdout);
//printf("helaaaalo\n");
int cnt=0,Max=0;
while(cin>>a[cnt]&&a[cnt++][0]!='.');
str="";
string s;
while(cin>>s)
str+=s;
for(int i=0;i<str.length();i++)
{
    for(int j=0;j<cnt;j++)
    {
        if(i+strlen(a[j])<=str.length());
        {
            bool jud=true;
            for(int k=0;k<strlen(a[j]);k++)
            {
                if(str[i+k]!=a[j][k])
                {
                    jud=false;
                    break;
                }
            }
            if(jud)
            {
                if(Max<i+strlen(a[j]))
                Max=i+strlen(a[j]);
            }
        }
    }
    if(i+1>Max)
    break;
}
   printf("%d\n",Max);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值