Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that
W[m[1]] < W[m[2]] < … < W[m[n]]
and
S[m[1]] > S[m[2]] > … > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
题意:求体重递增速度递减的最长序列。
用dp[i]记录在第i只老鼠的所在序列的最长长度,注意逆向输出(可以递归,也可以入栈)。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n,m;
int pre[1005];
struct q
{
int id;
int w;
int s;
}mice[1005];
struct p
{
int minn;
int num;
}dp[1005];
int mark[1005][1005];
bool cmp(q a,q b)
{
return a.w<b.w;
}
bool cmp1(p a,p b)
{
return a.num<b.num;
}
void print(int a)
{
if(pre[a]==0)
printf("%d\n",mice[a].id);
else
{
print(pre[a]);
printf("%d\n",mice[a].id);
}
}//逆向输出
int main (void)
{
int ww,ss,t=1;
while(~scanf("%d %d",&ww,&ss))
{
//if(ww==0&&ss==0)
// break;
mice[t].w=ww;
mice[t].s=ss;
mice[t].id=t;
//printf("%d %d\n",mice[t].w,mice[t].s);
t++;
}
memset(pre,0,sizeof(pre));
sort(mice+1,mice+t,cmp);
//dp[1].minn=0;
m=0;
for(int i=1;i<t;i++)
{
dp[i].num=1;
//初始化每只老鼠都是自己的一个序列,长度为1
}
int x;
int cnt=0;
int j;
for(int i=1;i<t;i++)//遍历i只老鼠
{
for(j=1;j<t;j++)
{
if(mice[i].w==mice[j].w)//如果i老鼠和j老鼠体重一样
break;
if(mice[i].s<mice[j].s)//否则
{
if(dp[i].num<dp[j].num+1)//如果当前序列比较短
{
dp[i].num=dp[j].num+1;
//dp[i].minn=mice[i].s;
//dp[i].num++;
pre[i]=j;
//记录这只老鼠,表示i老鼠能被j老鼠更新
}
}
}
}
int maxid=1;
for(int i=1;i<t;i++)
{
if(dp[maxid].num<dp[i].num)
maxid=i;
}
printf("%d\n",dp[maxid].num);
print(maxid);
//sort(dp+1,dp+t+1,cmp1);
return 0;
}
还有入栈逆向输出:
stack <int> st;
int mm=maxid;
while(mm!=0)
{
st.push(mm);
mm=pre[mm];
}
while(!st.empty())
{
printf("%d\n",mice[st.top()].id);
st.pop();
}