S-Nim
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6549 Accepted Submission(s): 2772
Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
The players take turns chosing a heap and removing a positive number of beads from it.
The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:
Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
If the xor-sum is 0, too bad, you will lose.
Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
The player that takes the last bead wins.
After the winning player’s last move the xor-sum will be 0.
The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a ‘W’.If the described position is a losing position print an ‘L’. Print a newline after each test case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
LWW
WWL
题意:就是要你求一下每种情况的SG值异或起来,0就是负态,非0就是胜态。
首先这里TLE了第一次从头到尾的暴力寻找,因为有很多重复的其实是不需要找的。
然后第二次卡住了了STL的时间,TLE第二发。
接着就改成VIS数组记忆化搜索了。
恩,感觉被游戏玩了一晚上。
还需要继续好好理解,gg。
代码:
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <set>
const int MAXN=10005;
int k;
int m;
int maxx;
int a[MAXN];
int x[MAXN];
int sg[MAXN+1];
using namespace std;
int getsg(int b)
{
if(sg[b]!=-1)
return sg[b];//搜索过了
if(b<a[0])//无解的情况
{
sg[b]=0;
return 0;
}
bool vis[100];
memset(vis,0,sizeof(vis));
// set<int>s;
for(int j=0;j<k;j++)
{
if(a[j]<=b)
{
int c=getsg(b-a[j]);
vis[c]=1;
}
}
int ans=0;
while(vis[ans]!=0)
{
ans++;
}
sg[b]=ans;
return sg[b];
}
void solve()
{
int xx=0;
for(int i=0;i<m;i++)
{
scanf("%d",&x[i]);
int d=getsg(x[i]);
xx^=d;
}
if(xx!=0)
{
printf("W");
return ;
}
else
{
printf("L");
return ;
}
}
int main (void)
{
while(~scanf("%d",&k))
{
if(k==0)
break;
for(int i=0;i<k;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+k);
memset(sg,-1,sizeof(sg));
int num;
scanf("%d",&num);
while(num--)
{
scanf("%d",&m);
solve();
}
printf("\n");
}
return 0;
}