HDU 5996 dingyeye loves stone (树形博弈)

dingyeye loves stone

                                                                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                  Total Submission(s): 59    Accepted Submission(s): 34

Problem Description
dingyeye loves play stone game with you.

dingyeye has an n -point tree.The nodes are numbered from 0 to n1 ,while the root is numbered 0 .Initially,there are a[i] stones on the i -th node.The game is in turns.When one move,he can choose a node and move some(this number cannot be 0 ) of the stones on it to its father.One loses the game if he can't do anything when he moves.

You always move first.You want to know whether you can win the game if you play optimally.
 

Input
In the first line, there is an integer T indicating the number of test cases.

In each test case,the first line contains one integer n refers to the number of nodes.

The next line contains n1 integers fa[1]fa[n1] ,which describe the father of nodes 1n1 (node 0 is the root).It is guaranteed that 0fa[i]<i .

The next line contains n integers a[0]a[n1] ,which describe the initial stones on each nodes.It is guaranteed that 0a[i]<134217728 .

1T100 , 1n100000 .

It is guaranteed that there is at most 7 test cases such that n>100 .
 

Output
For each test case output one line.If you can win the game,print "win".Ohterwise,print "lose".
 

Sample Input
  
  
2 2 0 1000 1 4 0 1 0 2 3 3 3
 

Sample Output
  
  
win lose 传送门: http://acm.hdu.edu.cn/showproblem.php?pid=5996

思路: 树形博弈。 对于第 2、4、6层的数不用考虑(连续上移两次即可);对于第1、3、5、7层的数,如果全部节点权值抑或,最后得到0(对一个高度为奇数的点进行的操作,即移动到高度为偶数进行处理)。

#include <queue>
#include <functional>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
#include <vector>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <assert.h>
#define REP(i,k,n) for(int i=k;i<n;i++)
#define REPP(i,k,n) for(int i=k;i<=n;i++)
#define scan(d) scanf("%d",&d)
#define scann(n,m) scanf("%d%d",&n,&m)
#define mst(a,k)  memset(a,k,sizeof(a));
#define LL long long
#define eps 1e-8
#define INF 0x3f3f3f3f
#define inf INF*INF
#define upmo(a,b) (((a)=((a)+(b))%mo)<0?(a)+=mo:(a))
#define mod 1000000007
using namespace std;
#define N 100005

int f[N];
int num[N];
int ans;
int main()
{
  int t;
  scan(t);
  while(t--){
   int n;
   scan(n);
   REP(i,1,n){
   int nn;
   scan(nn);
   f[i] = f[nn] + 1;
   }
   REP(i,0,n) scan(num[i]);
   ans = 0;
   REP(i,1,n){
   if(f[i]&1) ans^=num[i];
   }
   if(!ans) printf("lose\n");
   else printf("win\n");
  }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值