android support包与androidx冲突的问题解决

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/swallow_csdn/article/details/82982821

2、项目依赖的库

3、错误信息:

3、解决方法:

compile 'com.github.chrisbanes:PhotoView:+'

改为compile 'com.github.chrisbanes:PhotoView:2.1.3'

因为compile 'com.github.chrisbanes:PhotoView:+'使用的是最新版本2.2.0,该版本依赖androidx的相关包(见图一)。

而android support包与androidx不能同时存在,只能使用它们中的一种作为依赖,否则就会报上述的错误

展开阅读全文

没有更多推荐了,返回首页