HDU1024 Max Sum Plus Plus

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8

题目的意思是给定一个数组,求将其分成m个不相交字段和最大值的问题。
状态转移方程:dp[i][j]表示以i为结尾元素的j个字段的和
则dp[i][j] = max(dp[i-1][j] , dp[i-k][j-1]) + a[i];其中j-1<=k<=n+m+1

import java.util.Scanner;


public class P1024 {

    final int INF = Integer.MAX_VALUE;
    final int MAXN = 1000010;
    int[] dp  = new int[MAXN];
    int[] pre_max  = new int[MAXN];
    int[] num  = new int[MAXN];

    public static void main(String[] args) {
        new P1024().run();
    }

    //dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
    public void run(){
        Scanner scanner = new Scanner(System.in);
        int m, n;
        while (scanner.hasNextInt()) {
            m = scanner.nextInt();
            n = scanner.nextInt();
            int maxx =  -INF;
            for (int i = 1; i <= n; i++) {
                num[i] = scanner.nextInt();
                dp[i] = 0;
                pre_max[i] = 0;
            }

            dp[0] = 0;
            pre_max[0] = 0;
            for (int i = 1; i <= m; i++) {
                maxx = -INF;
                for (int j = i; j <= n; j++) {
                    dp[j] = Math.max(dp[j-1] + num[j], pre_max[j-1] + num[j]);
                    pre_max[j - 1] = maxx;
                    maxx = Math.max(maxx, dp[j]);
                }
            }
            System.out.println(maxx);
        }
        scanner.close();
    }

}

注:OJ上运行的时候将类名换成Main。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值