Chip Factory(01字典树求异或最大值)

题目描述

 

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip
produced this day has a serial number si.
At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

which i, j, k are three different integers between 1 and n. And is symbol of bitwise XOR.
Can you help John calculate the checksum number of today?

 

输入

The first line of input contains an integer T indicating the total number of test cases.
The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1 , s2 ,..., sn , separated with single space, indicating serial number of each chip.

  • 1≤T≤1000
  • 3≤n≤1000
  • 0≤s i≤109
  • There are at most 10 testcases with n > 100

 

输出

For each test case, please output an integer indicating the checksum number in a line.

 

样例输入

2
3
1 2 3
3
100 200 300

 

样例输出

6
400

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e3+5;
int ch[32 * maxn][2], val[32 * maxn], sz;

void init() {
	ch[0][0] = ch[0][1] = 0;
	memset(val, 0, sizeof(val));
	sz = 1;
}

void _insert(ll a) {
	int u = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a >> i) & 1);
		if (!ch[u][c]) {
			ch[sz][0] = ch[sz][1] = 0;
			ch[u][c] = sz++;
		}
		u = ch[u][c];
		val[u]++;
	}
}

void _delete(ll a) {
	int u = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a>>i)&1);
		u = ch[u][c];
		val[u]--;
	}
}
ll query(ll a) {
	int u = 0;
	ll ans = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a>>i)&1);
		if (c == 1) {
			if (ch[u][0] && val[ch[u][0]]) {
				ans += 1ll<<i;
				u = ch[u][0];
			} else {
				u = ch[u][1];
			}
		} else {
			if (ch[u][1] && val[ch[u][1]]) {
				ans += 1ll<<i;
				u = ch[u][1];
			} else {
				u = ch[u][0];
			}
		}
	}
	return ans;
}
ll a[1005];
int main() {
	int T, n;
	scanf("%d", &T);
	while (T--) {
		init();
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%lld", &a[i]);
		sort(a, a + n);
		for (int i = 0; i < n; i++)
			_insert(a[i]);
		ll maxx = 0;
		for (int i = 0; i < n; i++) {
			_delete(a[i]);
			for (int j = i + 1; j < n; j++) {
				_delete(a[j]);
				ll ans = query(a[i] + a[j]);
				maxx = max(maxx, ans);
				_insert(a[j]);
			}
			_insert(a[i]);
		}
		printf("%lld\n", maxx);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值