HDU 2458 Kindergarten (最大独立集)

H - Kindergarten
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers 
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and 
the number of pairs of girl and boy who know each other, respectively. 
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other. 
The girls are numbered from 1 to G and the boys are numbered from 1 to B. 

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4



题意大概是,给你三个数,G,B,M。分别是女生的数目,男生的数目以及将要给出的男生和女生的编号的组数。。接着给出M组数据,,每组数据中包括一个女生的编号和一个男生的编号,而且所有的男生都认识,所有的女生都认识。。如果G,B,M全部为0时则不输出。。最后要求出最大的一个选法,,让被选择的人中全部都互相认识。。刚开始看到题时,以为是一道并查集的题来着,,敲了敲,发现需要两个集合,但是两个集合的编号还一样。。所以我把他们放在了同一个集合中。果断WA。最后看了题解说是最大独立集。。把所有数据的女生向上传值,找到和他不认识的,然后return。。计数,,最后用所有男生+女生的和-所计数目。就是最大结果。。



#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <map>
#include <queue>
#include <stack>
#include <functional>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a));
#define For(a,b) for(int i = a;i<b;i++)
#define LL long long
#define MAX_N 100010
using namespace std;
int p[300],mark[300][300],link[300];
int G,B,M,g,b;
int f_ind(int x)
{
    for(int i = 1; i<=B; i++)
    {
        if(!mark[x][i] && !p[i])
        {
            p[i] =1;
            if(link[i] == 0 || f_ind(link[i]))
            {
                link[i] = x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int cas = 0;
    while(~scanf("%d %d %d",&G,&B,&M)&&G&&B&&M)
    {
        mem(mark,0);
        int ans = 0;
        for(int i = 0; i<M; i++)
        {
            scanf("%d %d",&g,&b);
            mark[g][b] = 1;
        }
        mem(link,0);
        for(int i = 1; i<=G; i++)
        {
            mem(p,0);
            if(f_ind(i)) ans ++;
        }
        printf("Case %d: %d\n",++cas,G+B-ans);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值