POJ - 3734 Blocks 矩阵的快速幂


Language:
Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6476 Accepted: 3121

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6


本题大意是给你n个方块排成列,然后有红黄蓝绿四种颜色。让你用这四种颜色对这n个方块进行染色。

求染成红色和绿色同时为偶数的方案一共有多少种情况。最后不要忘了对10007进行取模运算。


为什么作这道题呢。因为最近在研究一道蓝桥杯的往年试题 —— 斐波那契。这道题的取值范围到了10的18次幂。

所以说直接进行递归或者for循环显然不能满足题目的时间limited

所以就要用到矩阵的幂运算,再加上数的快速幂等算法,才能够在时间允许的情况下算出结果。虽然过了测试样例但还是显示错误.

给20分还不如我直接用for循环(40)做得分高呢,真的不知道如何改进了。扯远了,扯远了。。

设ai为满足两种颜色都为偶数的情况

bi为只有一种颜色满足偶数的情况

ci则是两种颜色都不满足是偶数的情况

对于 i+1时:

a_i+1 = 2*ai + bi;

b_i+1 = 2*ai + 2*bi + 2*ci;

c_i+1 = bi + 2*ci;

所以便得到了矩阵,如下:

|  2   1   0  |

|  2   2   2  |

|  0   1   2  |

然后就是剩下抹代码的工作了...



#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <map>
#include <sstream>
#include <queue>
#include <stack>
#include <vector>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define For(a,b) for(int i = a;i<b;i++)
#define ll long long
#define MAX_N 100010

using namespace std;
typedef vector<int> vec;
typedef vector<vec> mat;
const int mod = 10007;
mat mul(mat &A, mat &B)
{
    mat C(A.size(),vec(B[0].size()));
    for(int i = 0; i<A.size(); i++)
    {
        for(int k = 0; k<B.size(); k++)
        {
            for(int j = 0; j<B[0].size(); j++)
            {
                C[i][j] = (C[i][j] + A[i][k] * B[k][j]) % mod;
            }
        }
    }
    return C;
}

mat pow(mat A,int n)
{
    mat B(A.size(),vec(A.size()));
    for(int i = 0; i<A.size(); i++)
        B[i][i] = 1;
    while(n>0)
    {
        if(n & 1) B = mul(B,A);
        A = mul(A,A);
        n >>= 1;
    }
    return B;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        mat A(3,vec(3));
        A[0][0] = 2,A[0][1] = 1,A[0][2] = 0;
        A[1][0] = 2,A[1][1] = 2,A[1][2] = 2;
        A[2][0] = 0,A[2][1] = 1,A[2][2] = 2;
        A = pow(A,m);
        printf("%d\n",A[0][0] % mod);

    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值