HOJ-2277

Source : SCU Programming Contest 2006 Final
Time limit : 1 sec
Memory limit : 64 M

 

A class went to a school trip. And, as usually, all N kids have got their backpacks stuffed with candy. But soon quarrels started all over the place, as some of the kids had more apples than others. Soon, the teacher realized that he has to step in: "Everybody, listen! Put all the apples you have on this table here!"

Soon, there was quite a large heap of apples on the teacher's table. "Now, I will divide the apples into N equal heaps and everyone will get one of them." announced the teacher. "Wait, is this really possible?" wondered some of the smarter kids.

You are given the number of apples each child brought. Find out whether the teacher can divide the apples into N exactly equal heaps. (For the purpose of this task, all apples are of the same type.)

Input

The first line of the input file contains an integer T specifying the number of test cases. Each test case is preceded by a blank line.

Each test case looks as follows: The first line contains N(1 <= N <= 100) – the number of children. Each of the next N lines contains the number of apples one child brought which is less than 128.

Output

For each of the test cases output a single line with a single word "YES" if the apples can be distributed equally, or "NO" otherwise.

Sample Input

2

5
5
2
7
3
8

6
7
11
2
7
3
4

Sample Output

YES
NO
 
#include <stdio.h>
#include <iostream>
using namespace std;

class CASE
{
public:
	int num_chilren;
	int num_apple_per_child[100];
	int YES_NO;
};

int Num_Apple_Total(int n, int m[])
{
	int num_apple_total = 0;		
	for (int i = 0; i < n; ++i)	
	{
		cin >> m[i];
		num_apple_total += m[i];		
	}
	return num_apple_total;
}

void YES_NO(int k)
{
	if (k == 0) cout << "YES" << endl;
	else cout << "NO" << endl;
} 

int main(int argc, char const *argv[])
{
	int n_case;
	cin >> n_case;
	CASE *a = new CASE[n_case];
	for (int i = 0; i < n_case; ++i)
	{
		cin >> a[i].num_chilren;
		a[i].YES_NO = Num_Apple_Total(a[i].num_chilren, a[i].num_apple_per_child) % a[i].num_chilren;
		getchar();
	}
	for (int i = 0; i < n_case; ++i)
		YES_NO(a[i].YES_NO);
	delete a;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值