UVa 10780 Again Prime? No Time. (数论&素因子分解)

262 篇文章 0 订阅
100 篇文章 0 订阅

10780 - Again Prime? No Time.

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=467&page=show_problem&problem=1721

The problem statement is very easy. Given a number n you have to determine the largest power of m, not necessarily prime, that divides n!.

 

Input

 

The input file consists of several test cases. The first line in the file is the number of cases to handle. The following lines are the cases each of which contains two integers m (1<m<5000) and n (0<n<10000). The integers are separated by an space. There will be no invalid cases given and there are not more that 500 test cases.

Output

 

For each case in the input, print the case number and result in separate lines. The result is either an integer if m divides n! or a line "Impossible to divide" (without the quotes). Check the sample input and output format.

 

Sample Input

2
2 10
2 100

Sample Output

Case 1:
8
Case 2:
97

完整代码:

/*0.012s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 5010;
const int INF = 10000;

int prime[671], cnt;
bool vis[N];

inline void create_prime()
{
	for (int i = 2; i < N; ++i)///生成5010内的素数,多求一点
		if (!vis[i])
		{
			prime[cnt++] = i;
			for (int j = i * i; j <= N; j += i)
				vis[j] = true;
		}
}

inline int count(int n, int prime)
{
	int sum = 0;
	while (n > 1)
	{
		sum += n / prime;
		n /= prime;///另一种统计方法:改变n的值
	}
	return sum;
}

inline int index(int m, int prime)
{
	int index = 0;
	while (m % prime == 0)
	{
		++index;
		m /= prime;
	}
	return index;
}

int main(void)
{
	create_prime();
	int T, m, n, mm;
	scanf("%d", &T);
	for (int cas = 1; cas <= T; ++cas)
	{
		scanf("%d%d", &m, &n);
		mm = INF;
		for (int i = 0; prime[i] <= m; i++)
			if (m % prime[i] == 0)
			{
				mm = min(mm, count(n, prime[i]) / index(m, prime[i]));///核心代码
				if (mm == 0)
					break;
			}
		printf("Case %d:\n", cas);
		if (mm)
			printf("%d\n", mm);
		else
			puts("Impossible to divide");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值