10189 - Minesweeper
Time limit: 3.000 seconds
The Problem
Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):
*... .... .*.. ....If we would represent the same field placing the hint numbers described above, we would end up with:
*100 2210 1*10 1110As you may have already noticed, each square may have at most 8 adjacent squares.
The Input
The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.
The Output
For each field, you must print the following message in a line alone:
Field #x:Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.
Sample Input
4 4 *... .... .*.. .... 3 5 **... ..... .*... 0 0
Sample Output
Field #1: *100 2210 1*10 1110 Field #2: **100 33200 1*100
有一个利用数字大小来简化代码的技巧,详见代码。
完整代码:
#include<cstdio>
#include<cstring>
int a[120][120];
int main(void)
{
int n, m, count = 1, i, j,ii,jj;
while (scanf("%d%d", &n, &m),n)
{
getchar();
if (count > 1) putchar('\n');
char ch;
memset(a,0,sizeof(a));
for (i = 1; i <= n; i++)
{
for (j = 1; j <= m; j++)
{
scanf("%c", &ch);
if (ch == '*')
{
a[i][j] = 11;///小技巧
for (ii = i - 1; ii <= i + 1; ii++)
for (jj = j - 1; jj <= j + 1; jj++)
a[ii][jj]++;
}
}
getchar();
}
printf("Field #%d:\n", count);
for (i = 1; i <= n; i++)
{
for (j = 1; j <= m; j++)
{
if (a[i][j] > 10) putchar('*');
else printf("%d", a[i][j]);
}
putchar('\n');
}
count++;
}
return 0;
}