POJ 3544 Journey with Pigs (贪心&排序不等式)

Journey with Pigs

Time Limit:  1000MS
Memory Limit: 65536K

Description

Farmer John has a pig farm near town A. He wants to visit his friend living in town B. During this journey he will visit n small villages so he decided to earn some money. He tooks n pigs and plans to sell one pig in each village he visits.

Pork prices in villages are different, in the j-th village the people would buy a pork at pj rubles per kilogram. The distance from town A to the j-th village along the road to town B is dj kilometers.

Pigs have different weights. Transporting one kilogram of pork per one kilometer of the road needs t rubles for addition fuel.

Help John decide, which pig to sell in each town in order to earn as much money as possible.

Input

The first line of the input file contains integer numbers n (1 ≤ n ≤ 1000) and t (1 ≤ t ≤ 109). The second line contains n integer numbers wi (1 ≤ wi ≤ 109) — the weights of the pigs. The third line contains n integer numbersdj (1 ≤ dj ≤ 109) — the distances to the villages from the town A. The fourth line contains n integer numbers pj (1 ≤ pj ≤ 109) — the prices of pork in the villages.

Output

Output n numbers, the j-th number is the number of pig to sell in the j-th village. The pigs are numbered from 1 in the order they are listed in the input file.

Sample Input

3 1
10 20 15
10 20 30
50 70 60

Sample Output

3 2 1

Source

Northeastern Europe 2007, Northern Subregion

思路:首先根据村庄离A的距离和单位路程的花费,以及当地猪肉的价格,我们可以把到达每一个村庄卖猪单位重量赚的钱算出来。然后,按收益降序排列,再把猪的重量降序排序,这时,根据排序不等式,就可以达到最大盈利了。
维基百科——排序不等式

完整代码:
/*32ms,216KB*/

#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;

struct Node
{
	ll value;
	int position;
	bool operator < (const Node a) const
	{
		return value > a.value;
	}
} weight[1010], earn[1010];

ll dis[1010];
int ans[1010];

int main(void)
{
	int n;
	ll t;///单位运费
	while (~scanf("%d%lld", &n, &t))
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%lld", &weight[i].value);
			weight[i].position = i;
		}
		for (int i = 1; i <= n; i++)
			scanf("%lld", &dis[i]);
		for (int i = 1; i <= n; i++)
		{
			ll x;
			scanf("%lld", &x);
			earn[i].value = x - dis[i] * t;
			earn[i].position = i;
		}
		sort(weight + 1, weight + 1 + n);
		sort(earn + 1, earn + 1 + n);
		for (int i = 1; i <= n; i++)
			ans[earn[i].position] = weight[i].position;
		for (int i = 1; i < n; i++)
			printf("%d ", ans[i]);
		printf("%d\n", ans[n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值