POJ 3617 Best Cow Line

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23767 Accepted: 6455

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD


题目大意:一个农夫有一大堆牛,要给这些牛安排一个进场顺序,每次把在原队列最前面或最后面的牛放到正式队伍的尾部,使整个队伍的字典序最小。


算法:一眼看过去就应该是贪心,不过对于如果最前面或者最后面相同该如何判断是一个难点,博主自己卡了许久,最后找到一个奇怪的方法,不多说下面贴代码~


#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<ctime>

using namespace std;

int main()
{
	int n,h,t,i;
	char s[2010];
	char ans[2010];
	int j;
	scanf("%d",&n);
	getchar();
	for (i=1;i<=n;i++)
	{
		scanf("%c",&s[i]);
		getchar();
	}
	h=1;
	t=n;
	i=1;
	while (h<=t)
	{
		/*if (s[h]==s[t])
		{
			if (int(s[h+1]) < int(s[t-1]))
			{
				ans[i]=s[h];
				h++;
			}
			else
			{
				ans[i]=s[t];
				t--;
			}
		} 
		
		else if (int(s[h]) < int(s[t]))
		{
			ans[i]=s[h];
			h++;
		}
		else if (int(s[h]) > int(s[t]))
		{
			ans[i]=s[t];
			t--;
		}*/
		bool left=false;
		for (j=0;h+j<=t;j++)
		{
			if (s[h+j]<s[t-j])
			{
				left=true;
				break;
			}	
			else if (s[h+j] > s[t-j])
			{
				break;
			}
		} 
		if (left)
		{
			ans[i]=s[h];
			h++;
		}
		else
		{
			ans[i]=s[t];
			t--;
		}
		i++;
	}
	

	for (j=1;j<=n;j++)
	{
		cout<<ans[j];
		if (j%80==0)
		{
			cout<<endl;
		}
	}
    return 0;
}

注释掉的就是我的错误方法。。天真地以为第一个不一样判断第二个就好了,数据啪啪打脸。另外每80字符换行也是要注意的地方。


一天做了两个题。。这速度还可以。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值