POJ 3069 Saruman's Army


一道足足做了三天(当然其中还穿插着别的半成品555)的题。


Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10006 Accepted: 5034

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

题目大意:在一个数轴上有N个点,现要在这N个点其中挑选一些点加上标记,要求所有有标记的点的R范围以内能包含所有点(换言之,对于每一个点,在它的R范围之内必须有一个被标记的点),求最少需要标记多少点。


思路:一上来感觉也看不出是个什么算法,但是画个图(高手请忽略此步骤)可以发现, 有一些只有傻子才会做的操作:标记最左面或者最右面的点。不难看出这样会浪费距离,而且再一想每一个点都必须被包含所以完全可以线性顺次标记,所以很自然的想到贪心,代码附上。


#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<ctime>

using namespace std;

const int MAXN=1010;

void work(int r,int n)
{
	int x[MAXN];
	int i;
	
	for (i=0;i<n;i++)
	{
		scanf("%d",&x[i]);
	}
	sort(x,x+n);
	int ans=0;
	i=0; 
	while (i<n)
	{
		int s=x[i++];
		while (i<n && x[i]<=s+r)
		{
			i++;
		}
		int p=x[i-1];
		while (i<n && x[i]<=p+r)
		{
			i++;
		}
		ans++;
	}
	printf("%d\n",ans);
}

int main()
{
	int a,b;
	scanf("%d%d",&a,&b);
	while (a!=-1 && b!=-1)
	{
		work(a,b);
		scanf("%d%d",&a,&b);
	}
    return 0;
}

这次数组下标从0开始!此处s是没有被覆盖的最左边的点的位置,p是每一次新加的点的位置。注意while循环中i<n,没有等号!!博主在这个地方提供了一次分母。。。


要加速了不然没法每天一题了233。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值