POJ 3579 median

Median
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7493 Accepted: 2555

Description

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8


题目大意:有一个序列,将其任意两个数的差生成一个新的序列,求这个序列的中位数。


思路:数据范围太大,肯定不能一个一个算,所以二分答案,问题就变成了判定生成的这个序列中小于等于答案
的数的个数是否小于等于n*(n-1)/4.具体做法:首先将原数组a排序,设枚举值为x,枚举区间[l,r),在r增加的情况下,要使区间内的数都大于a[r]-x,则l单调不递减,r单调递增。


附代码

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<ctime>

using namespace std;
const int MAXN=100005;
int a[MAXN];

int main()
{
	int n;
	while (scanf("%d",&n)!=EOF)
	{
		int m=(n-1)*n/4;
		if ((n*(n-1)/2)&1)
		{
			m++;
		}
		if (n==1)
		{
			cout<<0<<endl;
			continue;
		}
		
		memset(a,0,sizeof(a));
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		sort(a+1,a+1+n);
		long long l=0,r=a[n],mid,num,j;
		while (l<r)
		{
			mid=(l+r)>>1;
			j=1;
			num=0;
			for (int i=2;i<=n;i++)
			{
				while (a[i]-a[j]>mid)
				{
					j++;
				}
				num+=(i-j);
			}
			if (num>=m)
			{
				r=mid;
			}
			else
			{
				l=mid+1;
			}
		}
		cout<<l<<endl;
	}
    return 0;
}

哇昨天一天A了4个题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值